Docker upgrade redmine from v3.4 to v4.1

Added by Alexander Pedersen 2 months ago

Hello

Im running redmine v3.4 in Docker, how can I upgrade to v4.1
Do i just change the version in docker-compose.yml from 3.4 to 4.1, or are there specific steps I have to do manually?

Replies (5)

RE: Docker upgrade redmine from v3.4 to v4.1 - Added by Liane Hampe 2 months ago

Hi Alexander,

Upgrading Redmine is almost the same as installing a version the first time since the newer version of Redmine will be substituted with the older one. Before doing so, some data and files should be backuped, see https://www.redmine.org/projects/redmine/wiki/RedmineUpgrade. Consider also plugins and themes which may have data to be backuped.

When you use Redmine via Docker then the process depends on how the underlying Dockerfile/docker-entrypoint.sh and your docker-compose.yml is designed. Perhaps you should ask the authors of your dockerized Redmine. There might be some automatically steps that requires some other actions than in a default Redmine upgrade.

Best Regards,
Liane

RE: Docker upgrade redmine from v3.4 to v4.1 - Added by Alexander Pedersen 2 months ago

Hi Liane,

Thanks for your answer.
I'm using the "Docker Official Image" : https://hub.docker.com/_/redmine
I'd guess it's the docker team or community that's behind those images (https://github.com/docker-library/redmine)

RE: Docker upgrade redmine from v3.4 to v4.1 - Added by Liane Hampe 2 months ago

Yes, it is the Docker community. I have had a look at their image, but I don't use it. I know that they copy the Redmine version you request form the Redmine releases here on the official Redmine Website and unzip it in the Dockerfile. That, is everything you did not mount for persistence will be lost.

RE: Docker upgrade redmine from v3.4 to v4.1 - Added by Alexander Pedersen 2 months ago

I made it work.
I just edited the version in the docker-compose.yml file and outcommented the "plugins" folder to test it out.
The only issue I had was I had to rename 'plugins/Redmine-All-Issues' to 'plugins/redmine_all_issues', and I had to upgrade to a newer version of "redmine_lightbox2" plugin (master branch)
Other than that, all my modules are working again and im now running Redmine 4.1.1 :)

(1-5/5)