"« Enabled modules » is invalid" Error when creating new Projects.

Added by Bernie Telles almost 10 years ago

Has anyone ever received this mysterious error when trying to create a new project? (screenshot is attached)

8 errors:

  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid
  • « Enabled modules » is invalid

Replies (2)

RE: "« Enabled modules » is invalid" Error when creating new Projects. - Added by Bernie Telles almost 10 years ago

By the way, here's the platform information:

- Ruby implementation and version: MRI/1.8.5
- Rails version (rails --version): 2.1.2
- Operating system : Solaris
- Database used, and its version: MySQL 5.0.67
- Ruby-aware server used: Phusion Passenger

Enabled Module entries in DB had null values. - Added by Bernie Telles almost 10 years ago

I manually created some projects with script/console and somehow ended up with a set of records in "enabled_modules" where the project_id was null. After removing those records the application worked again.

(1-2/2)