Wiki formatting disable parsing

Added by Davide Zipeto about 10 years ago

HI all,

I noticed that in the wiki documentation they is written the < pre> tag. How they managed to do that ? When I try to write this tag [without the space] I end up having another pre element defined

Is there a way to temporary disable the parsing and just display the raw HTML I am entering ?

Replies (5)

RE: Wiki formatting disable parsing - Added by Davide Zipeto about 10 years ago

Any further tips on this ? I tried with exclamation marks but it is not working with the pre tag.

RE: Wiki formatting disable parsing - Added by Mischa The Evil about 10 years ago

Davide Zipeto wrote:

I noticed that in the wiki documentation they is written the < pre> tag.

Can you provide a link to the specific page?

RE: Wiki formatting disable parsing - Added by Davide Zipeto about 10 years ago

Hey Misha,

it seems that in this page

http://www.redmine.org/boards/2/topics/9925

they are using the < pre> tag inside another < pre> tag to achieve

<pre>
test
</pre>

Is is possible jsut to write the < pre> tag on a line by disabling temporarly the textile markup engine ? I cannot find any tricks with that...

Thx !

RE: Wiki formatting disable parsing - Added by Mischa The Evil about 10 years ago

Davide Zipeto wrote:

Is is possible jsut to write the < pre> tag on a line by disabling temporarly the textile markup engine ? I cannot find any tricks with that...

A neat trick (AFAIK not officially supported by Redmine (nor RedCloth)) can be the use of Redmine's inline code markup.

With a nifty syntax the following results can be achieved: <pre>, [[links]], </code>, </pre>, <code>, h1. and _italic_.

I've posted the source of this reply to a gist to easily show the syntax I've used for the examples: http://gist.github.com/258248.

 
Kind regards,

Mischa.

RE: Wiki formatting disable parsing - Added by Davide Zipeto about 10 years ago

COOL !

good trick now working as expected ! Thank you !

(1-5/5)