Project

General

Profile

Actions

Defect #11010

closed

Redmine 2.0 does not support Microsoft Quotes

Added by Anonymous about 12 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

If I try to add the following to my Notes/Description of a Redmine ticket




I am getting a 500 - Internal Server Error

Actions #1

Updated by Anonymous about 12 years ago

Information About my Redmine Environment

We upgraded from 1.4.1 to 2.0.0 and running on IIS

Environment:
Redmine version 2.0.0.stable.9706
Ruby version 1.9.3 (i386-mingw32)
Rails version 3.2.3
Environment production
Database adapter MySQL
Redmine plugins:
no plugin installed

Actions #2

Updated by Etienne Massip about 12 years ago

  • Assignee deleted (Jean-Philippe Lang)
  • Resolution set to Cant reproduce

Can't reproduce on trunk / PostgreSQL + MRI 1.9.3.

Make me think of #8416.

Actions #3

Updated by Etienne Massip about 12 years ago

Could very well be related to the use of IIS.

Actions #4

Updated by Anonymous about 12 years ago

#8416 is the issue with single quotes but not the microsoft quotes

Actions #5

Updated by Etienne Massip about 12 years ago

Could you please check your Redmine and IIS logs?

Actions #6

Updated by Anonymous about 12 years ago

From Redmine logs

Started GET "/redmine/issues/1752" for 10.1.217.244 at 2012-05-24 09:44:59 -0700
Processing by IssuesController#show as HTML
Parameters: {"id"=>"1752"}
Rendered issues/_action_menu.html.erb (0.0ms)
Rendered issue_relations/_form.html.erb (0.0ms)
Rendered issues/_relations.html.erb (0.0ms)
Rendered issues/_history.html.erb (0.0ms)
Rendered issues/show.html.erb within layouts/base (31.2ms)
Completed 500 Internal Server Error in 187ms

ActionView::Template::Error (incompatible character encodings: UTF-8 and ASCII-8BIT):
114: <% if @journals.present? >
115: <div id="history">
116: <h3><
=l(:label_history)%></h3>
117: <%= render :partial => 'history', :locals => { :issue => @issue, :journals => @journals } >
118: </div>
119: <
end %>
120:
app/views/issues/show.html.erb:117:in `_app_views_issues_show_html_erb__669033008_44865480'
app/controllers/issues_controller.rb:118:in `block (2 levels) in show'
app/controllers/issues_controller.rb:115:in `show'

Actions #7

Updated by Jean-Philippe Lang about 12 years ago

Are you using the mysql2 adapter?

Actions #8

Updated by Jean-Philippe Lang about 12 years ago

  • Status changed from New to Closed
  • Resolution changed from Cant reproduce to Invalid

Oh, I can see that you're not using mysql2 in the info you provided.
Please change your database adapter to mysql2 (instead of mysql) in your config/database.yml.

Actions #9

Updated by Anonymous about 12 years ago

Yes I have mysql2 in my yml file. I have production and development adapter as mysql2

Actions #10

Updated by Anonymous about 12 years ago

  • Status changed from Closed to Reopened
Actions #11

Updated by Anonymous about 12 years ago

It is showing the same error in the redmine log file though I have mysql2 in the database adapter

Actions #12

Updated by Anonymous about 12 years ago

Is there anything to do with libMySQL.dll in C:\Ruby19\bin?

Actions #13

Updated by Anonymous about 12 years ago

In the Gem list it is showing both mysql and mysql2

Actions #14

Updated by Go MAEDA 5 months ago

  • Status changed from Reopened to Closed
Actions

Also available in: Atom PDF