Defect #11283

Adding time to an issue where a custom field regexp doesn't match adds the time spent twice

Added by Sepp _ almost 8 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Cant reproduce Affected version:2.0.3

Description

Adding time to an new issue where a custom field regexp (emailadress) doesn't match,
adds the time spent twice, when you correct the missing data in the "custom field" and resubmit the issue.

Associated revisions

Revision 10621
Added by Jean-Philippe Lang over 7 years ago

Test that spent time should not be added when issue update fails (#11283).

History

#1 Updated by Jean-Philippe Lang almost 8 years ago

Adding time to an new issue

How do you do that? AFAIK, there's no way to enter a spent time when creating a new issue.

#2 Updated by Jean-Philippe Lang almost 8 years ago

  • Resolution set to Cant reproduce

And I can't reproduce when adding time to an existing issue.

#3 Updated by Sepp _ almost 8 years ago

I was wrong, this was just the second step after creating the issue.
I just tried it a second time after upgrading to 2.0.3.

To reproduce:
  • Set ^[a-zA-Z0-9][\w\.-]*(?:[a-zA-Z0-9][a-zA-Z0-9_-]+\.)+[A-Za-z]{2,5};?.*$ as a Custom Field-Rexexp for validating Emailadresses
  • Create a new issue
  • Update the issue with a wrong emailadress and add hours to it.
  • correct the emailadress and submit again: --> The hours are added twice.

#4 Updated by Jean-Philippe Lang over 7 years ago

I still can't reproduce with 2.1 by following these steps, hours are saved only after the valid update.
I have also added a test in r10621 to make sure that spent time is not added when validation fails.

#5 Updated by Go MAEDA over 3 years ago

  • Category set to Time tracking
  • Status changed from New to Closed

No feedback for years. Closing.

Also available in: Atom PDF