Defect #12079

Redmine Upgrade issue 2.1.2

Added by parakrama ranasinghe over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Invalid Affected version:2.1.2

Description

Hi guys

im trying to upgrade to redmine 2.1.2 from redmine 1.3.1 , but i got the following error,

when i ran command ,

rake db:migrate RAILS_ENV=production

Error:,

rake aborted!
undefined local variable or method `config' for main:Object

Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)

So i ran it with trace option ..

  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    undefined local variable or method `config' for main:Object
    /opt/redmine/redmine-2.1.2/plugins/engines/init.rb:3
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
    /opt/redmine/redmine-2.1.2/lib/redmine/plugin.rb:130:in `load'
    /opt/redmine/redmine-2.1.2/lib/redmine/plugin.rb:121:in `each'
    /opt/redmine/redmine-2.1.2/lib/redmine/plugin.rb:121:in `load'
    /opt/redmine/redmine-2.1.2/config/initializers/30-redmine.rb:13
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in `load'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in `load'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:245:in `load'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:588
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:587:in `each'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:587
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:30:in `instance_exec'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:30:in `run'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:55:in `run_initializers'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:54:in `each'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/initializable.rb:54:in `run_initializers'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:136:in `initialize!'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `send'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `method_missing'
    /opt/redmine/redmine-2.1.2/config/environment.rb:14
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:103:in `require'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:103:in `require_environment!'
    /usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:295:in `initialize_tasks'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/monitor.rb:242:in `synchronize'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run'
    /usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
    /usr/bin/rake:19:in `load'
    /usr/bin/rake:19
    Tasks: TOP => db:migrate => environment

guys please provide me some help sort the issue ... im stuck here...

History

#1 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

There's no lib/plugins/engines in Redmine 2.0 and above. Please don't put anything in lib/plugins.
Try to migrate without plugins firt, then install your plugins in the plugins directory at the root of your Redmine directory.

Also available in: Atom PDF