Ruby 2.0 support
|Assignee:||Jean-Philippe Lang||% Done:|
Ruby2.0: add "require 'yaml'" to Gemfile
On ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]:
$ ruby script/about There was an error in your Gemfile, and Bundler cannot continue.
Fixed that #reload raises a Stack too deep error with ruby 2.0.
Regexp not working as expected with ruby 2.0.
Test failure with ruby 2.0.
#4 Updated by Etienne Massip almost 9 years ago
Please note that Redmine doesn't work with Ruby 2.0.0 under Windows for now because of numerous gem incompatibilities when gems bundle binaries compiled against specific Ruby versions and not 2.0.
Observed with sqlite3 and freetds gems.
This should be stated in documentation.
#6 Updated by Etienne Massip over 8 years ago
Matt Connolly wrote:
Etienne, did you upgrade from ruby 1.9.3? Ruby 2.0.0 has a new binary interface for extensions, so upgrading from 1.9.3 to 2.0.0 will require any gems with extensions to have those extensions recompiled.
That is true for sqlite3 indeed; as for SQL Server I was pretty sure I got errors from a fresh install on a 32 bit OS but it's been a while now and I don't remember well.
If you got success running Redmine 2.3.x with SQL Server on Windows, you can fix the guide or let me know and I'll remove the warning.