Project

General

Profile

Actions

Feature #13715

open

show SCM identifier (repository) in associated revisions

Added by Wim DePreter about 11 years ago. Updated almost 9 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
SCM
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

If there are multiple SCM per project (possible since 1.4.0, cfr #779), it would be nice to add the SCM identifier in the associated revisions overview.
For example:

Associated Revisions

scm01 - Revision 999
Added by ...
Bugfix for #...

scm02 - Revision 555
Added by ...
Update of documention for #...

Also in the detail of the revision, mentioning the SCM identifier would be nice.

P.S.: SCM identifier must be known by users if they want to reference the SCM-revision in wiki text


Related issues

Related to Redmine - Feature #5386: Branch/Tags in Changeset DescriptionNew2010-04-27

Actions
Related to Redmine - Feature #5242: Display source project for cross-project associated revisions for issuesClosedGo MAEDA2010-04-04

Actions
Has duplicate Redmine - Feature #16354: Add repository name to revisions on Associated revisions.Closed

Actions
Actions #1

Updated by Toshi MARUYAMA about 11 years ago

  • Tracker changed from Defect to Feature
Actions #2

Updated by chamnan khamwan about 11 years ago

(snip)

Actions #3

Updated by Wim DePreter about 11 years ago

I've noticed also another thing, when there are commit-messages in a certain SCM (not default in project) referencing another revision, f.e. r555, the revision in these commit-messages are interpreted by Redmine as hyperlinks, but refering to the default SCM.
Imho, the default SCM in commit-messages of an SCM should be the SCM itself (and not default SCM from Redmine)

Actions #4

Updated by Dipan Mehta about 11 years ago

+1.

I have one more aspiration on this front. When the commit is associated to revision it says "Revision 555". It would ideal if it can also point out if this revision was on 'trunk' or specific 'branch'.

Actions #5

Updated by Wim DePreter about 11 years ago

Dipan Mehta wrote:

I have one more aspiration on this front. When the commit is associated to revision it says "Revision 555". It would ideal if it can also point out if this revision was on 'trunk' or specific 'branch'.

Related feature for mentioning trunk/branch: #5386
I would keep the 2 features seperated, cause the info for my request is normally available in Redmine (no interpretation of SCM data necessary)

Actions #6

Updated by Wim DePreter almost 11 years ago

The SCM identifier is already mentioned in the activity overview, so same style should be used in associated revisions / detail of revision

Associated revisions

Revision 999 (scm01)
Added by ...
Bugfix for #...

Revision 555 (scm02)
Added by ...
Update of documention for #...

Actions #7

Updated by Wim DePreter about 9 years ago

This issue can be closed as duplicate of #16354

Actions #8

Updated by Toshi MARUYAMA almost 9 years ago

  • Target version set to Candidate for next minor release
Actions #9

Updated by Toshi MARUYAMA almost 9 years ago

  • Has duplicate Feature #16354: Add repository name to revisions on Associated revisions. added
Actions #10

Updated by Go MAEDA about 5 years ago

  • Related to Feature #5242: Display source project for cross-project associated revisions for issues added
Actions

Also available in: Atom PDF