Feature #15855

Add information about whether an issue is open or closed to Issues API response

Added by Michal Ciasnocha over 8 years ago. Updated 9 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:REST API
Target version:5.0.0
Resolution:

Description

When I get a list of issues I would like to know whether the issue is open or closed depending on the status. For example, an external application does not need to know specific statuses but just the open/closed information. According to a feature to filter issues by "open" or "closed" status I don't think it is difficult to involve this information to the issue element.

15855.patch Magnifier (3.1 KB) Takenori TAKAKI, 2021-08-11 01:16

15855-v2.patch Magnifier (4.25 KB) Takenori TAKAKI, 2021-08-17 10:17

Associated revisions

Revision 21225
Added by Go MAEDA 9 months ago

Add information about whether an issue is open or closed to Issues API response (#15855).

Patch by Takenori TAKAKI.

History

#1 Updated by Etienne Massip over 8 years ago

You can already get this information with Rest_IssueStatuses, I don't see the point of returning it with /issues, REST result is not supposed to be directly manipulated by humans?

#2 Updated by Michal Ciasnocha almost 8 years ago

I know I can get that information from Issue statuses, but I is necessary to make another request which is not effective. FYI I have an external system which retrieves all issues from Redmine (both open and closed) and I need to tell users their status.

#3 Updated by Takenori TAKAKI 11 months ago

I made a patch to implement this improvement and posted it.

#4 Updated by Takenori TAKAKI 11 months ago

I'll post a patch that also adds open or closed to 'allowed_statuses', which was added in #24976.

#5 Updated by Go MAEDA 10 months ago

  • Target version set to Candidate for next major release

#6 Updated by Go MAEDA 10 months ago

  • Target version changed from Candidate for next major release to 5.0.0

Setting the target version to 5.0.0.

#7 Updated by Go MAEDA 10 months ago

  • Subject changed from REST issue element could contain information whether the issue is open or closed to Add information about whether an issue is open or closed to Issues API response

#8 Updated by Go MAEDA 9 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you.

Also available in: Atom PDF