Defect #16173

API Rest // Customized fields for TimeEntries are not exported

Added by Samuel Samfra almost 8 years ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Cant reproduce Affected version:2.4.3

Description

Hello,

there is no way through the rest API to get the values of the customized fields of type TimeEntry...

thank you

History

#1 Updated by Go MAEDA over 1 year ago

  • Resolution set to Cant reproduce

A response of GET /time_entries/[id].(xml|json) contains custom fields.

{"time_entry":{"id":2,"project":{"id":1,"name":"eCookbook"},"issue":{"id":1},"user":{"id":1,"name":"Redmine Admin"},"activity":{"id":9,"name":"Design"},"hours":150.0,"comments":"","spent_on":"2007-03-12","created_on":"2007-03-23T13:11:04Z","updated_on":"2007-03-23T13:11:04Z","custom_fields":[{"id":10,"name":"Overtime"}]}}

#2 Updated by Go MAEDA about 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF