Project

General

Profile

Actions

Defect #1628

open

redmine sends http on forms on https server

Added by Michal Bielicki over 15 years ago. Updated about 13 years ago.

Status:
Reopened
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-07-12
Due date:
% Done:

50%

Estimated time:
Resolution:
Invalid
Affected version:

Description

I have the following configuration:
Glassfish v2UR2
jruby 1.1.2
rails 2.0.2

I have a http-listener on port 443 with security enabled.
Applications like xwiki, spree (rails shopping system) and others work fine.
redmine is supposed to be the root application on the system.

I had it all running fine with redmine-0.7.0 and updated to 0.7-stable from svn (I am running revision 1651). Now https://mywebserver/ redirects to http://mywebserver/login which of course does not exist.
When I manage to login by changing urls by hand, website links work fine, but all forms, like creating issues etc, still try to send to a http address instead of a https address.
THis was nt happening with 0.7.0


Related issues

Related to Redmine - Defect #1145: https - not all links use https but httpClosed2008-04-29

Actions
Related to Redmine - Defect #672: https and some application partClosed2008-02-15

Actions
Actions #1

Updated by Liwiusz Ociepa over 15 years ago

Have you checked settings.yml after update?

protocol:
  default: https

Maybe it was changed by svn update?

Actions #2

Updated by Jean-Philippe Lang over 15 years ago

Liwiusz, this setting has nothing to do with redirects.
It's only used to generate links in emails.

Actions #3

Updated by Andre Meij over 15 years ago

I had the same issue, I use apache forwarding to mongrel, where apache talks http to mongrel, this confuses mongrel into rewriting all urls to http.

For me the fix was adding this:

RequestHeader set X_FORWARDED_PROTO 'https'

In the apache config before the rewrite proxy rule

Hope this helps

Actions #4

Updated by Eric Davis over 15 years ago

Check #1145 for my Apache config.

Actions #5

Updated by Eric Davis over 15 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Resolution set to Invalid

Closing, issue is caused by a misconfigured web server and author hasn't responded. Reopen the issue if you are still having problems and please include any webserver configuration configuration. Thanks.

Actions #6

Updated by valqk valqk over 14 years ago

  • Status changed from Closed to Reopened
  • % Done changed from 100 to 50

I have the same problem.
I'm using nginx+modrails.
I've configured ONLY https and I get can't connect when redirected to http.
I've tried to put add_header X_FORWARDED_PROTO 'https'; for the vhost but nothing happens.
Redmine still redirects me to http:// instead of the https.
This only happens when redmine makes redirect_to. Forms are working.
I've tried to set
protocol:
default: https
in lib/redmine/hook.rb but nothing happened. same thing.
any ideas how to achieve redirect_to to work with correct URI scheme?

Actions #7

Updated by valqk valqk over 14 years ago

Also noticed that I get url rewritten even in return url (maybe because default scheme is http)
http://redmin.dom.eu/login?back_url=http%3A%2F%2Fredmin.dom.eu%2Fprojects%2Fshow%2Fsomeproject/

Actions #8

Updated by Alex Kuklin about 13 years ago

valqk valqk wrote:

I've tried to put add_header X_FORWARDED_PROTO 'https'; for the vhost but nothing happens.

Just to clarify.
Correct nginx config is:

        location /redmine {
                proxy_pass http://backend;
                proxy_set_header  Host        $http_host;
                proxy_set_header  X-Forwarded-For  $remote_addr;
                proxy_set_header  X-Forwarded-Ssl on;
                proxy_set_header  X-Forwarded-Proto https;
        }

X-Forwarded-Proto not X_Forwarded_Proto

Actions

Also available in: Atom PDF