Project

General

Profile

Actions

Feature #16523

closed

RESTful API: Expose custom fields project relations

Added by Florian Delizy almost 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
REST API
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

- it is impossible so far to know what custom fields is assigned to a project (only to the tracker)

A custom field can be activated on a tracker depending or which project the issue is filed on. In the /project/ID/custom_fields.xml request, all you get is a list of trackers the custom fields is assigned to, but not the list of projects it is assigned.

just like #16522, this also prevents the issue structure to be fully discovered automatically.

(BTW I also started a forum post about this: RESTful API missing some data to really be complete )


Related issues

Related to Redmine - Feature #16522: RESTful API: Expose tracker standard fields assignmentsClosed

Actions
Is duplicate of Redmine - Feature #33301: Add option to include enabled issue custom fields in projects#show API responseClosedGo MAEDA

Actions
Actions #1

Updated by Toshi MARUYAMA almost 10 years ago

  • Related to Feature #16522: RESTful API: Expose tracker standard fields assignments added
Actions #2

Updated by Anonymous almost 8 years ago

+1 to extend the API

Actions #3

Updated by Toshi MARUYAMA over 7 years ago

  • Description updated (diff)
Actions #4

Updated by Scott Little over 6 years ago

I also would like to extend the API to have this information.

To be more precise about the description, at least for me (and I think the original poster) — what needs to be exposed is the issue custom fields that are relevant for a project.

For me, it would actually be appropriate to have one the following values on the `custom_fields.:format` API result:

all_projects: [true|false]
project_ids: [list of ids]
Actions #5

Updated by Tom Quern over 3 years ago

This feature request is 6 years old. Are there any plans to eventually implement it?

An alternative approach to what was suggested above could be adding another parameter to the projects endpoint i.e. /projects.xml?include=custom_fields. See here of other parameters already available: https://www.redmine.org/projects/redmine/wiki/Rest_Projects#Showing-a-project

That way the API would expose the same information as presented in the 'Issue tracking' tab in the '/projects/<your-project>/settings/issues' page

Actions #6

Updated by Tom Quern over 3 years ago

Or is this is duplicate (and fixed by) #33301 ?

Actions #7

Updated by Go MAEDA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Tom Quern wrote:

Or is this is duplicate (and fixed by) #33301 ?

You are right. The feature will be available in the upcoming Redmine 4.2.0.

Actions #8

Updated by Go MAEDA over 3 years ago

  • Is duplicate of Feature #33301: Add option to include enabled issue custom fields in projects#show API response added
Actions

Also available in: Atom PDF