Defect #20483

V3.1/FC20 died NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper

Added by Pat Laporte over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:3.1.0

Description

Hello all,

I saw some issue for W32 but I'm on fedora 20
My installation fail (twice) with the same command, when I tried to generate a secret token

Any ideas to help or advice on this issue and
which version to run on centos or fedora ?

Thank You !
plap

ruby 2.0.0p353 (2013-11-22 revision 43784) [x86_64-linux]

[plap@hawaii redmine]$ /usr/local/bin/bundle exec rake generate_secret_token --trace

rake aborted!
NameError: uninitialized constant ActionView::Helpers::ActiveModelHelper
/usr/local/share/gems/gems/actionview-4.2.3/lib/action_view/helpers.rb:40:in `<module:Helpers>'
/usr/local/share/gems/gems/actionview-4.2.3/lib/action_view/helpers.rb:4:in `<module:ActionView>'
/usr/local/share/gems/gems/actionview-4.2.3/lib/action_view/helpers.rb:3:in `<top (required)>'
/usr/local/share/gems/gems/actionview-4.2.3/lib/action_view/base.rb:5:in `<top (required)>'
/usr/local/share/gems/gems/actionview-4.2.3/lib/action_view/view_paths.rb:1:in `<top (required)>'
/usr/local/share/gems/gems/actionpack-4.2.3/lib/abstract_controller/rendering.rb:4:in `<top (required)>'
/usr/local/share/gems/gems/actionpack-4.2.3/lib/action_controller/base.rb:204:in `<class:Base>'
/usr/local/share/gems/gems/actionpack-4.2.3/lib/action_controller/base.rb:164:in `<module:ActionController>'
/usr/local/share/gems/gems/actionpack-4.2.3/lib/action_controller/base.rb:5:in `<top (required)>'
/var/www/apache/.gem/ruby/gems/actionpack-action_caching-1.1.1/lib/action_controller/action_caching.rb:13:in `<top (required)>'
/var/www/apache/.gem/ruby/gems/actionpack-action_caching-1.1.1/lib/actionpack/action_caching.rb:1:in `require'
/var/www/apache/.gem/ruby/gems/actionpack-action_caching-1.1.1/lib/actionpack/action_caching.rb:1:in `<top (required)>'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler/runtime.rb:85:in `require'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler/runtime.rb:85:in `rescue in block in require'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler/runtime.rb:68:in `block in require'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler/runtime.rb:61:in `each'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler/runtime.rb:61:in `require'
/var/www/apache/.gem/ruby/gems/bundler-1.10.6/lib/bundler.rb:134:in `require'
/WWW/redmine-3.1.0/config/application.rb:5:in `<top (required)>'
/WWW/redmine-3.1.0/Rakefile:5:in `require'
/WWW/redmine-3.1.0/Rakefile:5:in `<top (required)>'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/rake_module.rb:28:in `load'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/rake_module.rb:28:in `load_rakefile'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:689:in `raw_load_rakefile'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:94:in `block in load_rakefile'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:176:in `standard_exception_handling'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:93:in `load_rakefile'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:77:in `block in run'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:176:in `standard_exception_handling'
/usr/local/share/gems/gems/rake-10.4.2/lib/rake/application.rb:75:in `run'
/usr/local/share/gems/gems/rake-10.4.2/bin/rake:33:in `<top (required)>'
/usr/local/bin/rake:23:in `load'
/usr/local/bin/rake:23:in `<main>'


[plap@hawaii redmine]$ gem list --local

  • LOCAL GEMS ***

actionmailer (4.2.3)
actionpack (4.2.3)
actionpack-action_caching (1.1.1)
actionpack-xml_parser (1.0.2)
actionview (4.2.3)
activejob (4.2.3)
activemodel (4.2.3)
activerecord (4.2.3)
activerecord-mysql2-adapter (0.0.3)
activesupport (4.2.3)
arel (6.0.3, 6.0.2)
bigdecimal (1.2.0)
builder (3.2.2)
bundler (1.10.6)
coderay (1.1.0)
erubis (2.7.0)
globalid (0.3.6, 0.3.5)
i18n (0.7.0)
io-console (0.4.2)
jquery-rails (3.1.3)
json (1.8.3, 1.7.7)
loofah (2.0.2)
mail (2.6.3)
mime-types (2.6.1)
mini_portile (0.6.2)
minitest (5.7.0)
mysql2 (0.3.19)
net-http-persistent (2.9.4)
net-ldap (0.3.1)
nokogiri (1.6.6.2)
passenger (5.0.15)
protected_attributes (1.1.3)
psych (2.0.0)
rack (1.6.4)
rack-openid (1.4.2)
rack-test (0.6.3)
rails (4.2.3)
rails-deprecated_sanitizer (1.0.3)
rails-dom-testing (1.0.6)
rails-html-sanitizer (1.0.2)
railties (4.2.3)
rake (10.4.2)
rbpdf (1.18.6)
rdoc (4.0.1)
redcarpet (3.1.2)
request_store (1.0.5)
rmagick (2.15.3)
ruby-openid (2.3.0)
sprockets (3.2.0)
sprockets-rails (2.3.2)
thor (0.19.1, 0.18.1)
thread_safe (0.3.5)
tzinfo (1.2.2)


Related issues

Duplicates Redmine - Defect #19952: Redmine is in error with Fedora 22 Closed

History

#1 Updated by Toshi MARUYAMA over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #19952.

#2 Updated by Toshi MARUYAMA over 6 years ago

  • Duplicates Defect #19952: Redmine is in error with Fedora 22 added

Also available in: Atom PDF