Feature #2051

Code view/pre div width

Added by Christoph Kappel over 11 years ago. Updated over 7 years ago.

Status:ClosedStart date:2008-10-19
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:

Description

The width for "pre" is set to 95% and this doesn't work well with enabled TOC. (div.wiki pre/application.css:456)
With visible TOC "pre" elements will appear below the TOC and not next to it.

My suggestion is to set the width to auto to fix it.


Related issues

Duplicated by Redmine - Defect #5795: Long wiki TOC and <pre> section breaks layout Closed 2010-07-01

History

#1 Updated by Harald Lapp over 11 years ago

this bug behaves different on different browsers:

  • safari: the code box is positioned above the toc, which is very annoying, because you -- of course -- can't read the toc in this case
  • firefox: the code box is pushed down -- which breaks the layout, somehow

i second the suggestion to set the width to 'auto'. this should fix this in both browsers.

#2 Updated by Christoph Kappel almost 11 years ago

It can't be to difficult to fix this - I have to change it manually everytime I update Redmine..

#3 Updated by Matthias Geier about 9 years ago

Is there a work-around (without changing the Redmine installation) until this gets fixed?

BTW, I think this one is a duplicate: #5795.

#4 Updated by Etienne Massip about 9 years ago

  • Target version set to Candidate for next minor release

Right, thanks.

#5 Updated by Jean-Philippe Lang about 9 years ago

Looks like it was done some time ago in r3615.
Anyone can confirm ?

#6 Updated by Etienne Massip about 9 years ago

Can't reproduce with trunk, indeed.

Matthias, could you please give some more details ?

#7 Updated by Etienne Massip about 9 years ago

  • Target version deleted (Candidate for next minor release)

#8 Updated by Daniel Felix over 7 years ago

Well i think, this ticket could be closed too. Doesn't it?

#9 Updated by Jean-Philippe Lang over 7 years ago

  • Status changed from New to Closed

Indeed.

Also available in: Atom PDF