Patch #214

Switch from numeric issue ids to symbolic ones

Added by Ted Wise almost 14 years ago. Updated over 10 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Switches issue ids from #1 to something like MYID-1

code_id.diff Magnifier (29.5 KB) Ted Wise, 2008-02-03 11:00

History

#1 Updated by Venkat Bagam over 13 years ago

I don't get what you are trying to achieve !!! do you mean that
you want to use customized MYID-1,MYID-2 ....so on as primary
keys rather than using auto-incremented integers ???

If that is so, I have a solution...

regards,
venkat

#2 Updated by bajs bajs over 13 years ago

Wrt /issues/show/proj-45:

That would break urls pointing to the old project if the issue
is moved to another project, wouldn't it?

Issues should have the same id even if they are moved. I see
no reason to have project-specific IDs.

Having a "print name" for ids could work though, so
that issue 123 is written as "PROJ-123" everywhere
it's written. But it should still have the same proper handle
IMO, and any inputting of IDs should then accept both 123 and
PROJ-123. But I wouldn't ever use it because...

Another issue with project-local ID numbers is that you can't
ever ever change the prefix. If your customer communication,
version control commits, wiki and everything else refers to issue
"FoodProj-123", then you can't really change FoodProjs
name to EatProj.

I wouldn't use the PROJ-prefix at all, but you go right ahead.
But please don't break globally unique issue IDs. That would
break so many things for so many potential users.

#3 Updated by Ted Wise almost 14 years ago

Yes, it's a very simplistic patch - basically it's just for
show. It displays issue id's as <CODE>-<ID>, e.g.,
PROJ-45,
but nothing else changes. For example, the url to access
the issue is still /issue/show/45.

To do this correctly, you really want to make the display
efficient, switch each project to have it's own id numbers
(instead of having id's shared across all projects), and use
code ids on the inbound, e.g., /issue/show/proj-45.

#4 Updated by Jeffrey Jones almost 14 years ago

Will the automatic linking code (used in comments and the wiki,
for example #20 will point to issue 20) work with the symbolic
ID?

#5 Updated by Felix Schäfer over 10 years ago

  • Status changed from New to Closed

I don't see much benefit in this for too much added complexity for end users.

Also available in: Atom PDF