Project

General

Profile

Actions

Defect #23430

closed

I can not access a closed project Issues

Added by Diego Gonzalez almost 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Cant reproduce
Affected version:

Description

Having closed the project and the Issues on it, I can not access them


Files

ClosedProjectIssues_1.JPG (29.7 KB) ClosedProjectIssues_1.JPG Diego Gonzalez, 2016-07-25 22:07
ClosedProjectIssues_2.JPG (28.3 KB) ClosedProjectIssues_2.JPG Diego Gonzalez, 2016-07-25 22:07
ClosedProjectIssues_3.JPG (29.5 KB) ClosedProjectIssues_3.JPG Diego Gonzalez, 2016-07-25 22:39
ClosedProjectIssues_4.JPG (70.9 KB) ClosedProjectIssues_4.JPG Diego Gonzalez, 2016-07-25 22:39
notvisible.png (10.8 KB) notvisible.png Jake Kemme, 2016-07-26 18:34
visible.png (14.1 KB) visible.png Jake Kemme, 2016-07-26 18:34
closed_issue_view.png (20 KB) closed_issue_view.png Jake Kemme, 2016-09-16 15:05
closed_overview.png (21.7 KB) closed_overview.png Jake Kemme, 2016-09-16 15:05
Actions #1

Updated by Diego Gonzalez almost 8 years ago

Diego Gonzalez wrote:

Having closed the project and the Issues on it, I can not access them

Add information, to have only one project open and information is displayed correctly

Actions #2

Updated by Toshi MARUYAMA almost 8 years ago

  • Status changed from New to Needs feedback

Please describe more details. What do you expect?

Actions #3

Updated by Diego Gonzalez almost 8 years ago

I have a main project "Closed projects" where I move closed subprojects. I have verified that if they are all closed, the access issues, can not filter them, I can not see any (image ClosedProjectIssues_2.JPG), however, if there is at least one open if I can see any issue within the closed projects (image ClosedProjectIssues_4.JPG).
I expect that while suproyectos are closed, I can access all the issues.

Thank you very much

Actions #4

Updated by Toshi MARUYAMA almost 8 years ago

I think it is expected behavior. See #12066 and #3640.

Actions #5

Updated by Jake Kemme almost 8 years ago

I have replicated this behavior in 3.3 - although I dont think it quite works as intended:

  • Main Project (open)
    • Closed Projects (open)
      • Child 1 (closed)
      • Child 2 (closed)
Issues for Child 1 and Child 2 are:
  • visible under Main Project
  • NOT visible under Closed Projects
  • visible under each child, respectively

  • Main Project (open)
    • Closed Projects (open)
      • Child 1 (closed)
      • Child 2 (closed)
      • Child 3 (open)
Issues for Child 1 and Child 2 are:
  • visible under Main Project
  • visible under Closed Projects
  • visible under each child, respectively

I wouldn't think this is the expected behavior one way, or the other for closed project issue visibility.

Actions #6

Updated by Toshi MARUYAMA almost 8 years ago

What do you mean "visible"?
Closed project is for "read-only" (#3640), so there is no "visible" difference (#12066).

Actions #7

Updated by Jake Kemme almost 8 years ago

visible pertains to the issues of a closed (read only) project from the perspective of the parent projects.

Issues visible Issues not visible
Actions #8

Updated by Toshi MARUYAMA almost 8 years ago

I still cannot reproduce on vanilla Redmine 3.3.0 and I cannot see what you expect.
What plugins do you use?

Actions #9

Updated by Jake Kemme over 7 years ago

Project heirarchy:

  • Main Project (open project)
    • Closed Projects (open project)
      • Child project 1 (closed project)
        • Issue 1.1 (open issue)
      • Child project 2 (closed project)
        • Issue 2.1 (open issue)
      • Child project 3 (open project)
        • Issue 3.1 (open issue)
Issues for projects Child 1, 2 and 3 are:
  • visible under Main Project/Issues
  • visible under Closed Projects/Issues
  • visible under each child/Issues, respectively

Now, close Child Project 3 (all sub projects of 'Closed Projects' are now closed)

  • Main Project (open project)
    • Closed Projects (open project)
      • Child project 1 (closed project)
        • Issue 1.1 (open issue)
      • Child project 2 (closed project)
        • Issue 2.1 (open issue)
      • Child project 3 (closed project)
        • Issue 3.1 (open issue)
Issues for projects Child 1, 2 and 3 are:
  • visible under Main Project/Issues
  • NOT visible under Closed Projects/Issues <-- This is not expected. Open issues of closed sub projects should still display
  • visible under each child/Issues, respectively
Actions #10

Updated by Toshi MARUYAMA over 7 years ago

  • Priority changed from High to Normal

I still cannot reproduce on vanilla Redmine 3.3.0.

Actions #11

Updated by Jake Kemme over 7 years ago

Im not sure where the differences are in our environments. I'll dig into the code to see if I can find a reason.

Environment:
  Redmine version                3.3.0.stable
  Ruby version                   2.2.1-p85 (2015-02-26) [x86_64-linux]
  Rails version                  4.2.6
  Environment                    development
  Database adapter               Mysql2
SCM:
  Subversion                     1.8.8
  Mercurial                      2.8.2
  Git                            1.9.1
  Filesystem                     
Redmine plugins:
  no plugin installed

The three issues from the sub projects show up in the overview count in the 'closed projects'

But, do not appear in the issues list of 'closed projects'.

Actions #12

Updated by Marius BÄ‚LTEANU over 5 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Cant reproduce

I'm closing this for now with "Cant reprodoce".

Please reopen if you still experience the issue on the latest Redmine versions.

Actions

Also available in: Atom PDF