Defect #23470

Disable "Select project modules" permission does not apply to the new project form

Added by Matteo Arceci about 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Project settings
Target version:3.4.0
Resolution:Fixed Affected version:3.3.0

Description

Hi,
i have disabled "Select project modules" for a role! this is the default role assigned to the user when creating new projects
from now on he cannot select modules on 'project settings' form (correct behaviour)

unfortunatelly he can still select modules on the 'new project' form!

My environment:
Platform Ubuntu Server 14.04.4 LTS

Environment:
  Redmine version                3.3.0.stable
  Ruby version                   2.3.0-p0 (2015-12-25) [x86_64-linux]
  Rails version                  4.2.6
  Environment                    production
  Database adapter               Mysql2
SCM:
  Filesystem                     
Redmine plugins:
  redmine_checklists             3.1.3
  redmine_contacts               4.0.4
  redmine_custom_help_url        0.0.2
  redmine_dmsf                   1.5.6
  redmine_favorite_projects      2.0.2
  redmine_ics_export             3.0.1.dev
  redmine_language_change        0.1.0
  redmine_monitoring_controlling 0.1.1
  redmine_people                 1.2.0
  redmine_stats                  0.0.3
  redmine_xlsx_format_issue_exporter 0.1.2
  sidebar_hide                   0.0.7


Related issues

Related to Redmine - Feature #1007: Create project for no administrator user Closed 2008-04-07

Associated revisions

Revision 15752
Added by Jean-Philippe Lang about 1 year ago

Disable "Select project modules" permission does not apply to the new project form (#23470).

History

#1 Updated by Toshi MARUYAMA about 1 year ago

  • Related to Feature #1007: Create project for no administrator user added

#2 Updated by Toshi MARUYAMA about 1 year ago

  • Status changed from New to Confirmed

#3 Updated by Toshi MARUYAMA about 1 year ago

  • Target version set to 3.4.0

#4 Updated by Jean-Philippe Lang about 1 year ago

  • Subject changed from disable "Select project modules" on role settings does not apply to the 'new project' form to Disable "Select project modules" permission does not apply to the new project form
  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fixed in r15752.

#5 Updated by Jean-Philippe Lang about 1 year ago

  • Status changed from Resolved to Closed

#6 Updated by Matteo Arceci about 1 year ago

  • Status changed from Closed to Reopened

Hi,
sorry but after upgrade files taken from r15752 i can still select modules on "new project form"

steps to reproduce:

  1. Administrator -> Settings -> Projects -> Role given to a non-admin user who creates a project -> "test1"
  2. Administrator -> Settings -> Roles and permissions -> "test1" -> Project -> Select project modules -> UNCHECK
  3. login as a "non admin" user
  4. Projects -> New project

in this form Modules section still show up with the ability to select / deselect modules

same environment

Kind regards,

#7 Updated by Matteo Arceci about 1 year ago

after some other tests i found that the problem is only in the view that still show up the "Modules fieldset"
check / uncheck modules as no effect on the new project created

#8 Updated by Jean-Philippe Lang about 1 year ago

  • Status changed from Reopened to Closed

Sorry, I'm not able to reproduce and there's a test for this exact use case that was added with the fix.
Make sure that you have properly applied the fix.

Also available in: Atom PDF