Feature #24550

Open GANTT for more than 24months

Added by Bastian L├╝ttig about 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution:Duplicate

Description

Hi,

we have projects that run for more than 24months and it is necessary to print a gantt chart over the whole project.
I'd like to increase it.

I suppose, changes necessary are in:
lib/redmine/helpers/gantt.rb

line 68: replace 24 by any number you like. Maybe we can make this a setting?
Additionally, the PNG generation needs some adaptation to fit the entire sheet on one page (font size, month/year shortened to month/2-digit-year)


Related issues

Duplicates Redmine - Feature #14654: Allow a bigger range for the gantt timeline Closed

History

#1 Updated by Go MAEDA about 2 years ago

  • Duplicates Feature #14654: Allow a bigger range for the gantt timeline added

#2 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #14654.

Also available in: Atom PDF