Defect #25555

Make api paging limit configurable

Added by George Brooke about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:Duplicate Affected version:

Description

Currently the API is limited to a maximum of 100 items in any one response [1], however on the other hand it is possible to configure the issue export limit.

I would like to be able to raise this number similarly to the export limit as this would allow us to pull info from the UI into our BI (which doesn't handle paging very well) to give us dashboards for management.

I realise that simply raising the limit is not a very elegant solution, however 100 is very low, and as we can handle displaying many more through the webui it seems like a reasonable work-around.

[1] Rest_api


Related issues

Duplicates Redmine - Patch #16069: Allow configuration of API limit instead of hardcoding at... New

History

#1 Updated by Go MAEDA about 3 years ago

  • Duplicates Patch #16069: Allow configuration of API limit instead of hardcoding at 100 added

#2 Updated by Go MAEDA about 3 years ago

  • Category set to REST API
  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #16069.
Thank you for suggesting improvement.

#3 Updated by Toshi MARUYAMA about 3 years ago

  • Description updated (diff)

Also available in: Atom PDF