Defect #25748

Spent time details CSV export: issues' id, tracker & subject columns merged into one issue column

Added by Jenda Benda over 4 years ago. Updated over 1 year ago.

Status:ConfirmedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution: Affected version:2.3.0

Description

Dear Redmine team!

We really appreciate all your work here. thanks for that.

I would like to ask you for an explanation and possibility of modification of Issue column in "Spent time - overall spent time - details view".

Could you please explain me, why (started/changed in some previous versions of redmine) “issue” column has been changed and consists of joint information of "tracker", "task ID", and "task subject"?

The think that relates to this is that "spent time" filter doesn’t offer those columns/attributes to be used as a filter within spent time detail view.

This makes impossible to filter and sort by those "attributes" of the spent time entries, which is something that was previously and would be very useful.

This makes impossible to export information into CSV with separated information/columns mentioned above.

This doesn’t follow database normalization rules I guess (I suppose this information is stored separately within DB)...so I don't understand the reason for this.

Could you please make this filtering possible and add possibility of adding those colums separately in the report and CSV export?

thanks a lot
Kind regards
JB

time-report-dropdown.png (26.8 KB) Toshi MARUYAMA, 2017-05-30 17:57

Screen Shot 2017-05-30 at 19.43.48.png - details view with joint information/values in Issue filed (41.8 KB) Jenda Benda, 2017-05-30 19:53

Redmine-1.4.png (32.1 KB) Toshi MARUYAMA, 2017-05-30 20:45

1.2-stable.png (30.8 KB) Toshi MARUYAMA, 2017-06-01 16:06

History

#1 Updated by Toshi MARUYAMA about 4 years ago

  • Subject changed from Spent time - Issue Column badly joins more infromation to Spent time - Issue Column badly joins more information

#2 Updated by Toshi MARUYAMA about 4 years ago

Jenda Benda wrote:

Could you please explain me, why (started/changed in some previous versions of redmine) “issue” column has been changed and consists of joint information of "tracker", "task ID", and "task subject"?

Do you mean this drop down?

#3 Updated by Jenda Benda about 4 years ago

Hi,

no this is not the place...I mean "details" view.. Please see my screenshot, that shows it. I also highlited all the values that are joint together with different colors.

We had to create custom field, where we copy/duplicate tracker information to be able to sort it in the view by tracker-custom field...

thx
jb

#4 Updated by Toshi MARUYAMA about 4 years ago

This is vanilla Redmine 1.4 screen shot.

Did you use vanilla Redmine?

#5 Updated by Jenda Benda about 4 years ago

my screenshot comes from this:

Redmine version                3.3.0.stable
Ruby version 2.1.10-p492
Rails version 4.2.6

#6 Updated by Toshi MARUYAMA about 4 years ago

Jenda Benda wrote:

Could you please explain me, why (started/changed in some previous versions of redmine) “issue” column has been changed and consists of joint information of "tracker", "task ID", and "task subject"?

What version do you mean as some previous versions?
There is no change from Redmine 1.4.

#7 Updated by Jenda Benda about 4 years ago

Hi,

thanks again!

We used redmine 1.2 before 3.3.x version. The spent time details view was as explained above there, the same was CSV export...

thx
jb

#8 Updated by Toshi MARUYAMA about 4 years ago

I cannot see any difference in Redmine 1.2.

#9 Updated by Jenda Benda about 4 years ago

could you please try to export CSV and check the result? Are the tracker, ID and Issue subject separated "columns"?
thanks a lot
JB

#10 Updated by Toshi MARUYAMA about 4 years ago

  • Subject changed from Spent time - Issue Column badly joins more information to Spent time csv: tracker column joins to issue column
  • Category set to Time tracking
  • Status changed from Needs feedback to Confirmed
  • Affected version set to 2.3.0

It seems caused by around r11448.

Redmine 2.2:

Date,User,Activity,Project,Issue,Tracker,Subject,Hours,Comment
06/01/2017,Redmine Admin,Design,test00,1,Bug,test,1.0,"" 

Redmine 3.3:

Project,Date,User,Activity,Issue,Comment,Hours
test_00,06/02/2017,Redmine Admin,Design,Bug #53: test,"",1.00

#11 Updated by Mischa The Evil about 4 years ago

I've been reading along and started digging the code of the 'spent time details view' when the TS explicitly expressed that this is scoped to the CSV export of that view only. I was able to trace this change in the CSV export to r11442, which was introduced first in Redmine 2.3.0.
Before r11442, the CSV export contained three individual columns (id, tracker and subject), whereas post r11442, the query columns are being used instead, which results in the fact that only one column is presented which includes a concatenation of the id, tracker and subject.

#12 Updated by Mischa The Evil about 4 years ago

  • Subject changed from Spent time csv: tracker column joins to issue column to Spent time details CSV export: issues' id, tracker & subject columns merged into one issue column

#13 Updated by Jenda Benda about 4 years ago

OK, thanks a lot...I probably wrongly expected that export was the same as the view in web UI, please let me aplogozie myself.
The fact is we were used to sort/filter/list by these three different values. We used CSV export and Excel for doing that in the past.

When we upgraded redmine the filter function in spent time details view was included(for web UI). So we've started using this great feature.
We still need to sort and filter(two different things) as well. Because it wasn't possible nor in the UI and nor in the CSV export we had to add custom fileds for trackers and others and duplicate this information there each time spent time entry was/is created, to be able to filter and sort by these values.

I believe there are two different issues then:
1. CSV export concatenates of the id, tracker and subject
2. web UI spent time details filter doesn't allows to filter/sort by the id, tracker and subject(as the attributes are concentated together in one field)

ad1) We know now there was change in the code for CSV export, but not sure if this was done on purpose...?
ad2) Is there any practical reason for not showing the ID, tracker and subjecct in spent time separatedly? If not I believe it would make sense and many users could benefit from separation of these attributes/values in web UI spent time details view.

Thanks a lot again for all the effort.
Kind regards
JB

#14 Updated by Jenda Benda over 3 years ago

Dears,

I hope you are all doing great!

Is there any update on this please?

I also believe this is related to the most recent version of redmine... not just to 2.3.0 as statet in issue atributes. This may lead to ignoring this issue.

Thanks lot
Kind regards
J.

#15 Updated by Jenda Benda about 2 years ago

I have to confirm this is not an issue in the latest stable version 4.0.3 anymore.
Thanks a lot!
j.

#16 Updated by Marius BALTEANU over 1 year ago

  • Status changed from Confirmed to Closed

Jenda Benda wrote:

I have to confirm this is not an issue in the latest stable version 4.0.3 anymore.
Thanks a lot!
j.

It's not an issue because of defect #33052 which most probably will be fixed in 4.1.1 because the expected behaviour is to have the issue displayed as "Tracker #id: #subject" (Bug #1: Cannot print recipes), please see #18269.

I think we should close this ticket with "Won't fix".

#17 Updated by Marius BALTEANU over 1 year ago

  • Status changed from Closed to Confirmed

Also available in: Atom PDF