Defect #28919

Cannot update issue when removing locked users to watchers list

Added by Vincent Caron over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:3.4.4

Description

Steps to reproduce (in my case with Redmine 3.4.4) :

  • create user 'bob'
  • create issue #1
  • add 'bob' to watcher list
  • lock 'bob' account
  • remove 'bob' from #1's watcher list
  • try to update #1 with a new comment

Result is 'watchers is invalid' and issue cannot be updated.

Workaround :
  • unlock 'bob' account
  • re-add 'bob' in #1's watcher list
  • lock 'bob' account

Summary : don't remove locked users to issue's watcher list, it's currently buggy.

History

#1 Updated by Go MAEDA over 3 years ago

I could not reproduce the problem with Redmine 3.4.5.

Do you use plugins? This issue may be caused by some plugins. Please try again after uninstalling all plugins.

#2 Updated by Vincent Caron over 3 years ago

Indeed, I have a few plugins. One is 'Redmine Auto Watch', seems a good candidate to turn off, I'll have a try.

#3 Updated by Vincent Caron over 3 years ago

  • Status changed from New to Resolved

OKayyy, that's definitively 'Redmine Auto Watch'. I could not reproduce the problem once this plugin was turned off.

Thanks a lot for the quick triaging, and sorry for the false report. I'll check with the plugin code and author.

#4 Updated by Go MAEDA over 3 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Thank you for sharing the information. I am happy to know that the plain Redmine has no problem and your Redmine instance is now working fine.

Also available in: Atom PDF