Defect #30431

Useless "Delete issues" tracker permission is shown on the role page for Anonymous and Non-member

Added by Go MAEDA about 1 year ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Permissions and roles
Target version:4.1.0
Resolution:Fixed Affected version:

Description

Since you cannot grant a "Delete issues" permission for Anonymous and Non-member roles, "Delete issues" column in the tracker permission table on the role page is useless. The column should be hidden like default "Reporter" role.

delete-issues-tracker-permission@2x.png (17.8 KB) Go MAEDA, 2019-01-15 07:03

30431.patch Magnifier (2.5 KB) Yuichi HARADA, 2019-04-26 06:57

30431-v2.patch Magnifier (1.21 KB) Go MAEDA, 2019-09-22 07:31

Associated revisions

Revision 18508
Added by Go MAEDA 5 months ago

Don't show unsettable permissions in the tracker permissions table (#30431).

Patch by Yuichi HARADA.

History

#1 Updated by Yuichi HARADA 10 months ago

It was displayed "Delete issues" column in the tracker permission table on the role page because it was not confirmed the settable permissions of the role.
I attached a patch.

#2 Updated by Go MAEDA 10 months ago

  • Target version set to Candidate for next minor release

#3 Updated by Go MAEDA 5 months ago

  • File 30431-v2.patchMagnifier added
  • Target version changed from Candidate for next minor release to 4.1.0

LGTM but I propose a slight change as follows. Using & operator is simpler and much faster than using delete_if.

<% permissions = [:view_issues, :add_issues, :edit_issues, :add_issue_notes, :delete_issues] & setable_permissions.collect(&:name) %>

Setting the target version to 4.1.0.

#4 Updated by Go MAEDA 5 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you for fixing this issue.

Also available in: Atom PDF