Defect #31140

"English" becomes unavailable from Redmine 4.0.3

Added by Ko Nagase about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:Invalid Affected version:4.0.3

Description

After upgrading Redmine 4.0.2 => 4.0.3, [My account] - [Language] setting's "English" option becomes unavailable.
[Redmine 4.0.2]

[Redmine 4.0.3]

redmine-4.0.2.png (12.4 KB) Ko Nagase, 2019-04-04 08:10

redmine-4.0.3.png (13.3 KB) Ko Nagase, 2019-04-04 08:10

en.png (41.3 KB) Toshi MARUYAMA, 2019-04-04 08:22

History

#1 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Needs feedback
  • Private changed from No to Yes

I cannot reproduce the problem.

Running 'bin/rails tmp:clear' under the installation directory of Redmine may fix it.

#2 Updated by Go MAEDA about 2 years ago

  • Private changed from Yes to No

#3 Updated by Toshi MARUYAMA about 2 years ago

I cannot reproduce too.

#4 Updated by Ko Nagase about 2 years ago

Thanks for quick advice!
I confirmed that running "bin/rails tmp:clear" solved the issue.

#5 Updated by Go MAEDA about 2 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Thank you for the feedback.

#6 Updated by Ko Nagase about 2 years ago

From further checking, I found that the issue cause was the followings.

  1. I created "ja.yml" file on 1 plugin with invalid "en:" key on Redmine 4.0.3 environment.
    (I forgot to replace the key to "ja:" after copying the file from "en.yml".)
    redmine
      +- plugins
        +- redmine_xxx
          +- config
            +- locales
              +- en.yml
              +- ja.yml (invalid "en:" key)
        +- :
    
  2. Before checking Redmine itself, I removed all plugins, but I didn't execute "bin/rails tmp:clear".

I am so sorry for bothering you by my mistake.

Also available in: Atom PDF