Defect #32309

settings error in 4.0.5.devel.18786

Added by ChunChang Lo 11 months ago. Updated 11 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:ChunChang Lo% Done:

0%

Category:-
Target version:-
Resolution: Affected version:

Description

Hello,

Just get the lastest version from subversion and the settings page is broken.

Internal error
An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

Back
ActionController::RoutingError (No route matches [GET] "/libs/js/iframe.js"):

actionpack (5.2.3) lib/action_dispatch/middleware/debug_exceptions.rb:65:in `call'
actionpack (5.2.3) lib/action_dispatch/middleware/show_exceptions.rb:33:in `call'
railties (5.2.3) lib/rails/rack/logger.rb:38:in `call_app'
railties (5.2.3) lib/rails/rack/logger.rb:26:in `block in call'
activesupport (5.2.3) lib/active_support/tagged_logging.rb:71:in `block in tagged'
activesupport (5.2.3) lib/active_support/tagged_logging.rb:28:in `tagged'
activesupport (5.2.3) lib/active_support/tagged_logging.rb:71:in `tagged'
railties (5.2.3) lib/rails/rack/logger.rb:26:in `call'
actionpack (5.2.3) lib/action_dispatch/middleware/remote_ip.rb:81:in `call'
actionpack (5.2.3) lib/action_dispatch/middleware/request_id.rb:27:in `call'
rack (2.0.7) lib/rack/method_override.rb:22:in `call'
rack (2.0.7) lib/rack/runtime.rb:22:in `call'
activesupport (5.2.3) lib/active_support/cache/strategy/local_cache_middleware.rb:29:in `call'
actionpack (5.2.3) lib/action_dispatch/middleware/executor.rb:14:in `call'
actionpack (5.2.3) lib/action_dispatch/middleware/static.rb:127:in `call'
rack (2.0.7) lib/rack/content_length.rb:15:in `call'
rack (2.0.7) lib/rack/sendfile.rb:111:in `call'
railties (5.2.3) lib/rails/engine.rb:524:in `call'
/usr/share/ruby/vendor_ruby/phusion_passenger/rack/thread_handler_extension.rb:97:in `process_request'
/usr/share/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:149:in `accept_and_process_next_request'
/usr/share/ruby/vendor_ruby/phusion_passenger/request_handler/thread_handler.rb:110:in `main_loop'
/usr/share/ruby/vendor_ruby/phusion_passenger/request_handler.rb:415:in `block (3 levels) in start_threads'
/usr/share/ruby/vendor_ruby/phusion_passenger/utils.rb:113:in `block in create_thread_and_abort_on_exception'

History

#1 Updated by Go MAEDA 11 months ago

I was not able to reproduce the problem with Redmine 4.0.5.devel.18786.

Could you describe details of how to reproduce the problem? Does "settings page" means /projects/IDENTIFIER/settings/* or /admin ?

#2 Updated by Marius BALTEANU 11 months ago

  • Status changed from New to Needs feedback
  • Assignee set to ChunChang Lo

libs/js/iframe.js is not part of Redmine core.

#3 Updated by ChunChang Lo 11 months ago

Hello,

this error occurs in the /settings page and the redmine instance doesn't install any 3rd-party plugins.

#4 Updated by ChunChang Lo 11 months ago

Hi,

Never mind. Just grabbed revision 18788 and the /setting works again (don't know why. i didn't do anything.)

#5 Updated by Go MAEDA 11 months ago

  • Status changed from Needs feedback to Closed

Thank you for the feedback. Closing.

Also available in: Atom PDF