Feature #32783

Redirect to index page instead of edit page after creating a new custom field

Added by Aleksandar Pavic 5 months ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Custom fields
Target version:4.2.0
Resolution:Fixed

Description

Current behavior:

1. Click o Create new custom field from some tab like Users
2. Create custom field and click save
3. You are staying on the same form

Desired behavior

step 3: Go back to Users tab and display new field there

The process of adding multiple custom fields would be improved this way

32783.patch Magnifier (1.21 KB) Go MAEDA, 2020-04-20 12:07


Related issues

Related to Redmine - Patch #33117: Redirect to users_path instead of edit_user_path in order... New

Associated revisions

Revision 19749
Added by Go MAEDA about 1 month ago

Redirect to index page instead of edit page after creating a new custom field (#32783).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA about 1 month ago

  • File 32783.patchMagnifier added
  • Target version set to Candidate for next major release

+1
Here is a patch to change the behavior as suggested.

#2 Updated by Go MAEDA about 1 month ago

  • Related to Patch #33117: Redirect to users_path instead of edit_user_path in order to avoid confusion added

#3 Updated by Go MAEDA about 1 month ago

  • Target version changed from Candidate for next major release to 4.2.0

Setting the target version to 4.2.0.

#4 Updated by Aleksandar Pavic about 1 month ago

Same problem is with other custom fields also, not just users.

If you create custom filed for issue, and save it, you are redirected to that field not
to issue's custom fields.

Same goes for documents etc...

#5 Updated by Go MAEDA about 1 month ago

Aleksandar Pavic wrote:

If you create custom filed for issue, and save it, you are redirected to that field not
to issue's custom fields.

Same goes for documents etc...

Do you mean that the behavior after applying 32783.patch is broken? I could not reproduce such wrong redirection.

I would like to investigate the problem, so could you describe details and steps to reproduce?

#6 Updated by Aleksandar Pavic about 1 month ago

It is good, sorry for confusion.

Thanks.

#7 Updated by Go MAEDA about 1 month ago

  • Subject changed from After creating custom field return to custom fields tab to Redirect to index page instead of edit page after creating a new custom field
  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch.

Also available in: Atom PDF