Defect #33042

Fix importing issues due to using the wrong tmp directory

Added by Gregor Borsemirk about 1 month ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:

Description

The debian package ships redmine in /usr/share/redmine and sets up
instances in /var/lib/redmine.

Without this change the issue importer attempts to create a directory in
the read-only /usr tree:
Completed 500 Internal Server Error
Errno::EACCES (Permission denied @ dir_s_mkdir - /usr/share/redmine/tmp):

Now it uses the intended tmp directory and issues can be imported again:
/var/lib/redmine/default/tmp/imports/350548aee641641463bc89cd6043738c

0001-Fix-importing-issues-due-to-using-the-wrong-tmp-dire.patch Magnifier (1.23 KB) Gregor Borsemirk, 2020-02-23 17:04

Screenshot_2020-02-24.png (55.6 KB) Go MAEDA, 2020-02-24 03:26

History

#1 Updated by Go MAEDA about 1 month ago

The patch cannot be applied to the core because Redmine does not have Redmine.root method. Please see the attached screenshot.

Probably the issue is specific to Debian. I recommend you to report this issue to the Debian team.

#2 Updated by Gregor Borsemirk about 1 month ago

  • Status changed from New to Resolved

#4 Updated by Marius BALTEANU about 1 month ago

  • Tracker changed from Patch to Defect
  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Thanks for detecting and reporting the issue to the Debian team. I'm closing this.

Also available in: Atom PDF