Feature #33254

Show open/closed badge on issue page

Added by Go MAEDA 7 months ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Issues
Target version:4.2.0
Resolution:Fixed

Description

#29391 added a useful badge that shows the status of the version. I think it would be nice to have the badge on Issue pages as well.

Currently, it is a bit hard to tell at a glance whether an issue is closed. Adding the badge can resolve the problem.

Bugzilla has a similar badge.

badge-on-issue.png (60.2 KB) Go MAEDA, 2020-04-05 09:37

bugzilla-badge.png (62.9 KB) Go MAEDA, 2020-04-05 09:51

dropdown_badge.png (74.2 KB) Marius BALTEANU, 2020-04-05 13:28

open.png (96.1 KB) Marius BALTEANU, 2020-04-18 16:35

closed.png (110 KB) Marius BALTEANU, 2020-04-18 16:35

0001-Show-open-closed-badge-on-issue-page.patch Magnifier (5.62 KB) Marius BALTEANU, 2020-04-18 17:22


Related issues

Related to Redmine - Patch #29391: Show version status in Roadmap and Version pages Closed
Related to Redmine - Feature #33153: UI feature to quickly change issue status New
Related to Redmine - Feature #33834: Show open/closed badge in email notifications Closed
Related to Redmine - Feature #33832: Move the "Private" badge next to the "Open/Closed" badge New

Associated revisions

Revision 19719
Added by Go MAEDA 6 months ago

Show open/closed badge on issue page (#33254).

Patch by Marius BALTEANU.

History

#1 Updated by Go MAEDA 7 months ago

  • Related to Patch #29391: Show version status in Roadmap and Version pages added

#2 Updated by Marius BALTEANU 7 months ago

I like the idea!

What do you think if we combine this with #33153 and show the status as a dropdown badge with a quick way to change the status?

#3 Updated by Go MAEDA 7 months ago

Marius BALTEANU wrote:

What do you think if we combine this with #33153 and show the status as a dropdown badge with a quick way to change the status?

I think it is really nice! My original request will be met if closed statuses have a different appearance than open statuses, like closed and open versions.

#4 Updated by Go MAEDA 7 months ago

  • Related to Feature #33153: UI feature to quickly change issue status added

#5 Updated by Marius BALTEANU 6 months ago

I've created a patch that adds the open/closed badge on issue.

Open issue:

Closed issue:

Test results here

Should we show only open/closed badge or we should show the issue status on blue badge if it's open and on green badge if it's closed?

#6 Updated by Go MAEDA 6 months ago

Marius BALTEANU wrote:

Should we show only open/closed badge or we should show the issue status on blue badge if it's open and on green badge if it's closed?

I think showing only open/closed is enough. The reason why I opened this issue is that it is hard to know at a glance whether the issue is open or closed. The patch resolves it very well.

If the current issue status is shown in the badge, maybe we will have to consider removing the status field that shows exactly the same information with the badge.

#7 Updated by Go MAEDA 6 months ago

  • Target version changed from Candidate for next major release to 4.2.0

Setting the target version to 4.2.0.

#8 Updated by Go MAEDA 6 months ago

  • Subject changed from Show open/closed status in Issue pages to Show open/closed badge on issue page
  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you for the nice improvement!

#9 Updated by Go MAEDA 3 months ago

  • Related to Feature #33834: Show open/closed badge in email notifications added

#10 Updated by Go MAEDA 8 days ago

  • Related to Feature #33832: Move the "Private" badge next to the "Open/Closed" badge added

Also available in: Atom PDF