Defect #35424

https://www.redmine.org/boards/2/topics/65661

Added by Jan Catrysse 6 months ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution:Duplicate Affected version:4.2.1

Description

Problem:
PNG export of GANTT chart throws an error: You must have ImageMagick or GraphicsMagick installed.

Error message

Environment:

  Redmine version                4.2.1.stable
  Ruby version                   2.7.3-p183 (2021-04-05) [amd64-freebsd12]
  Rails version                  5.2.6
  Environment                    development
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                sendmail

Redmine checks:

  Default administrator account changed: ok
  Attachments directory writable: ok
  Plugin assets directory writable (./public/plugin_assets): ok
  MiniMagick available (optional): ok
  ImageMagick convert available (optional): ok
  ImageMagick PDF support available (optional): ok

OS:

  FreeBSD 13.0 in AMD64

Libraries:

  ImageMagick7-7.0.11.12: installed
  rubygem-mini_magick-4.10.1: installed

Configuration.yml: (relevant part / leading whitespace = two spaces)

default:
  rmagick_font_path: /usr/local/share/fonts/dejavu/DejaVuSans.ttf
  imagemagick_convert_command: /usr/local/bin/convert

Description:
I cannot seem to use MiniMagick to export the PNG, but I have Image Magick installed, and the convert executable is working on command line.
I tried this patch #35027 but without change.

Somehow I think that MiniMagick::Tool::Convert is not using or finding the correct path to /usr/local/bin/convert.

I made a link to /usr/bin/convert: no success.
I tried running convert as user www: works fine on command line.

Help would be appreciated.
Best regards,
Jan

error.jpg - Error message (51.4 KB) Jan Catrysse, 2021-06-17 18:35


Related issues

Duplicates Redmine - Defect #35027: Gantt PNG export ignores imagemagick_convert_command New

History

#1 Updated by Go MAEDA 6 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I am closing this issue because the problem is being tracked in #35027.

#2 Updated by Go MAEDA 6 months ago

  • Duplicates Defect #35027: Gantt PNG export ignores imagemagick_convert_command added

Also available in: Atom PDF