Project

General

Profile

Actions

Feature #36659

closed

Add "auth_source_id" to GET request for Endpoint /users.:format

Added by Christoph Graf over 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Category:
REST API
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

In our Redmine installation we have both local users and users from our LDAP service. It would be very helpful for our user management if we could filter for "auth_source_id" in a GET request for the endpoint /users.:format.

Example:
GET /users.json?limit=100&auth_source_id=1


Related issues

Related to Redmine - Feature #23307: Include auth_source field in User API responseClosedGo MAEDA

Actions
Is duplicate of Redmine - Feature #37674: Upgrade Admin/Users list to use the query systemClosedGo MAEDA

Actions
Actions #1

Updated by Go MAEDA over 2 years ago

  • Related to Feature #23307: Include auth_source field in User API response added
Actions #2

Updated by Joan J over 1 year ago

There's a patch in the related feature #23307, could that be included in next release?

Actions #3

Updated by Marius BĂLTEANU 5 months ago

  • Status changed from New to Closed
  • Assignee set to Marius BĂLTEANU
  • Resolution set to Fixed

Starting with Redmine 5.1 (#37674) you can now filter for auth_source_id using the same syntax that exists for other entities. The one pointed by you should work as expected.

Actions #4

Updated by Marius BĂLTEANU 5 months ago

  • Is duplicate of Feature #37674: Upgrade Admin/Users list to use the query system added
Actions

Also available in: Atom PDF