Defect #37053

Attachments are lost when the status of the ticket is changed

Added by Marius BALTEANU 5 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Marius BALTEANU% Done:

0%

Category:Attachments
Target version:5.0.1
Resolution:Fixed Affected version:5.0.0

Description

From #36909#note-2:

Steps to reproduce:
  1. Edit ticket
  2. Select a file to attach
  3. The file appears at Files section
  4. Change issue status to other state

Right after the status change, the file listed at Files section, is removed, and the error above is printed on browser console.


Related issues

Related to Redmine - Defect #34641: When editing an issue, the Log time and/or Add notes does... Closed
Copied from Redmine - Defect #36909: Mentions not working if status is changed Closed

Associated revisions

Revision 21578
Added by Marius BALTEANU 5 months ago

Revert changes made to issue form update in r21495 (#37053).

Revision 21579
Added by Marius BALTEANU 5 months ago

Add test for #37053.

Revision 21580
Added by Marius BALTEANU 5 months ago

Fix that newly added attachments are lost when the status of the ticket is changed by hiding/showing the fields without removing them (#37053).

Revision 21581
Added by Marius BALTEANU 5 months ago

Merged r21578-r21580 to 5.0-stable (#37053).

History

#1 Updated by Marius BALTEANU 5 months ago

  • Copied from Defect #36909: Mentions not working if status is changed added

#2 Updated by Marius BALTEANU 5 months ago

This is caused by #34641.

#3 Updated by Marius BALTEANU 5 months ago

  • Related to Defect #34641: When editing an issue, the Log time and/or Add notes does not show or hide dynamically added

#4 Updated by Marius BALTEANU 5 months ago

  • Status changed from Confirmed to Resolved
  • Resolution set to Fixed

Fix committed with a test.

#5 Updated by Marius BALTEANU 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF