Defect #37676

Image base64 are not displayed

Added by Black Zajaz 19 days ago. Updated 18 days ago.

Status:ReopenedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:5.0.2

Description

After upgrade from 4.1.1 to 5.0.2 Images are not displayed.

Into Database are saved with html base64 code

<img alt="" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABoAAAAXCAIAAACatshHAAACUUlEQVQ4jd3Uy08TURQGcLb+F+7ZunDhTjduQOPOBxYCptgE0Uhs...." />

but this is not displayed into HTML.

<img alt="" height="397" width="701">

Why is source text not read?

History

#1 Updated by Black Zajaz 19 days ago

I'm need a workaround.

I have pictures from issues and wikis of last 10 years.

Anyone have an idea?

#2 Updated by Go MAEDA 18 days ago

  • Status changed from New to Needs feedback

Redmine core does not have a feature to embed an image using an img tag with base64 data. Probably it is a feature added by some plugin, isn't it?

I recommend you to contact the author of the plugin.

#3 Updated by Black Zajaz 18 days ago

I have contacted owner from ckeditor plugin.
Here is answer:

https://github.com/a-ono/redmine_ckeditor/issues/349#issuecomment-1156472120

:(

#4 Updated by Go MAEDA 18 days ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Unfortunately there is nothing we can do about the plugin.

#5 Updated by Black Zajaz 18 days ago

  • Status changed from Closed to Reopened

i don't want to use plugin, i just want support.

I look for alternatives.

#6 Updated by Go MAEDA 18 days ago

Since the problem is caused by a third-party plugin, it is not appropriate to open an issue here. Please use forums for asking for help.

If you need support for CK Editor plugin, maybe you can contact the RedmineX team.
https://www.redmine-x.com/redmine-x-plugins/roadmap/ck-editor-take-over

#7 Updated by C S 18 days ago

Do you still have CK Editor installed?
Which text formatter did you choose?
Currently the best solution: Common Markdown (~95% of the CK-Editor HTML code is translated by us)

#8 Updated by Black Zajaz 18 days ago

Thank, for answer.
But, i don't want to use plugin.
I'm need a workaround for convert pictures or a path for use base64 data.

You can close this issue.

:(

Also available in: Atom PDF