Project

General

Profile

Actions

Defect #38634

closed

Context menu doesn't work when using filter

Added by Nono Nono about 1 year ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues list
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

Since v5.0.5 the context menu (the 3 dots) does nothing when there is a filter selected, except this on the developer tool:
jquery-3.6.1-ui-1.13.2-ujs-6.1.7.js?1678052137:2 GET https://redmine.tld/issues/context_menu?utf8=%E2%9C%93&authenticity_token=pSKNrjrYBaoIpkbXQkS54VZ%2Bzu9fi81TeopMwE2VBPayqitIhnrlOgIs9eR9UHfZR9sfl3uuXGGCeQK0kQW2yw%3D%3D&back_url=%2Fissues%3Fquery_id%3D61&c%5B%5D=id&c%5B%5D=project&c%5B%5D=fixed_version&c%5B%5D=status&c%5B%5D=priority&c%5B%5D=subject&c%5B%5D=updated_on&c%5B%5D=done_ratio&c%5B%5D=due_date&ids%5B%5D=8181 404

The "context menu" DOES work, when I'm on the "My page" view or when there is no filter selected.

(sorry, I didn't find the 5.0.5 on "Affected version" below so I take the nearest I found.)


Files

Actions #1

Updated by Nono Nono 8 months ago

it still the case on 5.0.6

Actions #2

Updated by Mischa The Evil 8 months ago

  • Category changed from Issues to Issues list

I can't test this now but FTR: does the (functionally-equal) "regular" right-click menu work as expected with a selected custom query or is it broken as well?

Actions #3

Updated by Marius BĂLTEANU 8 months ago

  • Affected version changed from 5.0.4 to 5.0.5
Actions #4

Updated by Nono Nono 7 months ago

On the my/page it works
On any /projects/xxx/issues?query_id=xx or /issues?query_id=xx it does not work.

Actions #5

Updated by Marius BĂLTEANU 7 months ago

  • Status changed from New to Needs feedback

I cannot reproduce on current trunk.

Please post information about your instance from Administration -> Information (/admin/info).

Actions #6

Updated by Nono Nono 5 months ago

it's now fixed on 5.0.7

Actions #7

Updated by Marius BĂLTEANU 5 months ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

Thanks!

Actions

Also available in: Atom PDF