Project

General

Profile

Actions

Defect #39527

closed

Deprecate unused ApplicationHelper#render_if_exist

Added by Mischa The Evil 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Code cleanup/refactoring
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

ApplicationHelper#render_if_exist was introduced in r19799 for #33102. After discussion in that issue and subsequent issue #36524, it was decided to remove the sidebars from the import views after all with r21390 and r21391. It looks like that with that, ApplicationHelper#render_if_exist became unused and obsolete.
If it is indeed confirmed obsolete, it might be desirable to deprecate the method and remove it (along with its tests) in the end.

FWIW: the names of the test methods contain a typo; s/redner/render.


Files

39527.patch (2.06 KB) 39527.patch Go MAEDA, 2023-11-12 13:21
39527-v2.patch (2.16 KB) 39527-v2.patch Go MAEDA, 2023-11-16 07:54
Actions #1

Updated by Go MAEDA 7 months ago

It appears that render_if_exist is not being used as you have indicated.
The attached patch deprecates ApplicationHelper#render_if_exist.

Actions #2

Updated by Go MAEDA 7 months ago

Updated the patch. This updated patch also includes a fix for the method names in the test code.

Actions #3

Updated by Go MAEDA 7 months ago

  • Subject changed from ApplicationHelper#render_if_exist seems obsolete to Deprecate unused ApplicationHelper#render_if_exist
  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch in r22466. Thank you for pointing out this issue.

Actions

Also available in: Atom PDF