Project

General

Profile

Actions

Defect #40239

closed

Add missing fixtures in Redmine::ApiTest::IssuesTest

Added by Vincent Robert about 2 months ago. Updated 23 days ago.

Status:
Closed
Priority:
Normal
Category:
Code cleanup/refactoring
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

The test "POST /issues.xml with watcher_user_ids should create issue with watchers" in Redmine::ApiTest::IssuesTest
is failing if we run only this one.

We should add the fixture "user_preferences" in the issues_test.rb file.

It is due to the new "add_auto_watcher" features, which automatically set the author as a watcher by default. The author is added to all new issues if we don't load the preferences.

Actions #1

Updated by Marius BĂLTEANU about 2 months ago

  • Category set to Code cleanup/refactoring
  • Status changed from New to Closed
  • Assignee set to Marius BĂLTEANU
  • Resolution set to Fixed

Committed, thanks!

Actions #2

Updated by Vincent Robert 25 days ago

Hi.
It seems the revision has been backported to test/system/issues_test.rb instead of test/integration/api_test/issues_test.rb
I managed to reproduce the failing test with Redmine 5.1.2

Actions #3

Updated by Marius BĂLTEANU 23 days ago

Vincent Robert wrote in #note-2:

Hi.
It seems the revision has been backported to test/system/issues_test.rb instead of test/integration/api_test/issues_test.rb
I managed to reproduce the failing test with Redmine 5.1.2

You're right, sorry for this. I've merged now r22773 to 5.1-stable.

Actions

Also available in: Atom PDF