Defect #4592

Updating issues created with required custom field that are no longer in use by project

Added by Daniel Thorpe over 12 years ago. Updated over 12 years ago.

Status:ClosedStart date:2010-01-15
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

If a custom field is required and in use by a project when an issue is added. If subsequently that custom field is removed from a project, for whatever reason, perhaps it was a mistake etc. If you then try to update the issue in anyway way, such as to close it, then Redmine returns an error stating that the custom field is required.

This is on Redmine 0.9.0.devel.3281 (MySQL)

History

#1 Updated by Jean-Philippe Lang over 12 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce
I followed these steps:
  • added a required custom field to project A
  • created issue 1 in project A (had to fill the required custom field)
  • removed the custom field from project A
  • went back to issue 1
  • closed it without any error

In other words, I can't reproduce with latest trunk.

Also available in: Atom PDF