Project

General

Profile

Actions

Patch #4596

closed

REST api fto get account info ?

Added by Jérémy Lal about 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
REST API
Target version:
-
Start date:
2010-01-16
Due date:
% Done:

0%

Estimated time:

Description

Hi,
it could be very useful for other software that would want to authenticate against redmine,
to have /my/account.(json|xml) return account information (User.current).
Here's a small patch to provide this.


Files

rest_account.diff (1.5 KB) rest_account.diff patch against 0.9-stable Jérémy Lal, 2010-01-16 18:11

Related issues

Related to Redmine - Feature #296: REST APIClosedJean-Philippe Lang

Actions
Is duplicate of Redmine - Feature #6260: REST API for UsersClosed2010-09-01

Actions
Actions #1

Updated by Eric Hollering about 14 years ago

+1 Definitely would like to see this.

Actions #2

Updated by Jean-Philippe Lang almost 14 years ago

Sending the user's password hash in the response is not a good idea.

Actions #3

Updated by Adam Kaplan almost 14 years ago

Jean-Philippe Lang wrote:

Sending the user's password hash in the response is not a good idea.

I'm trying to get Redmine adopted by the NY Times and this API would be a critical step. I think a user information API would be very powerful feature:

  • Query for account existence
  • Ability to create an account stub
  • Retrieve core account info -- first, last, email

I'll create a more complex and secure patch based on the above.

Actions #4

Updated by Jean-Philippe Lang over 13 years ago

  • Status changed from New to Closed

The REST API for Users was added in trunk and will be available in 1.1.

Actions

Also available in: Atom PDF