Defect #5021

stylesheet_link_tag does not honor Redmine running out of a sub-uri if it is called from a plugin

Added by Robert Chady over 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:2010-03-09
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

If a plugin calls stylesheet_link_tag with the :plugin parameter, the link that gets inserted does not honor the sub-uri the system is running through. I believe this is caused by Engines::RailsExtensions::AssetHelpers#plugin_asset_path. This method returns a path that seems to assume the system is not running under a sub-uri.


Related issues

Duplicates Redmine - Defect #3935: stylesheet_link_tag with plugin doesn't take into account... Closed 2009-09-28

History

#1 Updated by Jérémie Delaitre over 10 years ago

I have the same problem with both stylesheet_link_tag and javascript_include_tag.

#2 Updated by Jérémie Delaitre over 10 years ago

This duplicates #3935

#3 Updated by Jean-Baptiste Barth about 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I close this one as duplicate, as #3935 is older and comes with a patch..

Also available in: Atom PDF