Project

General

Profile

Actions

Feature #605

closed

User groups!

Added by Milton Taylor about 15 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Administration
Target version:
-
Start date:
2008-02-05
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

This feature was asked for previously, but for a different reason, and was closed as not being necessary.

I believe it would be extremely useful to have a concept of a group of users purely for the purposes of simplifying project membership. If there are even a modest number of users, combined with a modest number of projects, the process of managing project membership starts to become exponential. Since it is often the case that a new user should get the same access rights as an existing user, it becomes greatly simplified if it is possible to just add that user to the appropriate group, where the group itself is a member of the project. A typical use-case is where you might have a group corresponding to a set of people at a particular customer, and another group representing your developers.

Of course it does mean that the code for presenting list boxes of users for issue assignment is slightly more complex, but not incredibly so.

An additional idea would be to allow the issue to be assigned to either an individual or a group. I think this might possibly intersect with feature request #525

We are happy to work on a patch for this...


Related issues

Is duplicate of Redmine - Feature #340: Assign to groupClosed

Actions
Is duplicate of Redmine - Feature #525: Issue State Owners + User GroupsClosed

Actions
Actions #1

Updated by Rahul Vaidya over 13 years ago

  • Status changed from New to Resolved

This functionality seems to be implemented in the development build already. Assigning issues to groups, on the other hand, is not, but this specific issue is not requesting this.

Actions #2

Updated by Jean-Philippe Lang about 13 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Fixed

Groups were added in 0.9.

Actions

Also available in: Atom PDF