Defect #6157

Applying custom queries should not redirect away from calendar or gantt pages

Added by Adam Soltys about 11 years ago. Updated about 8 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:

Description

If you have custom queries in place, they will be visible on the calendar and gantt pages as well as the issues page. Clicking on them always redirects you to the issues page though. You can go back to the calendar or gantt pages afterwards and the query will be applied, but it'd be nice if you weren't redirected away in the first place.

I'll start working on a patch for this issue.

retain_action_when_applying_custom_query.diff Magnifier (1.08 KB) Adam Soltys, 2010-08-17 17:25


Related issues

Related to Redmine - Patch #6688: Improvements for query-views of Calendar and Gantt Closed 2010-10-18

History

#2 Updated by Mischa The Evil about 11 years ago

Adam Soltys wrote:

I think this patch does it. Please review. [...]

This patch seems to work fine for me...

Note: the change in the CalendarsController has become obsolete after r4245.

#3 Updated by Daniel Felix almost 9 years ago

  • Status changed from New to Needs feedback

I'm currently not able to reproduce this. Anyone else can confirm this is fixed?

#4 Updated by Mischa The Evil about 8 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Fixed

Daniel Felix wrote:

I'm currently not able to reproduce this. Anyone else can confirm this is fixed?

Yes, I can. To be precise, it was fixed in r4909 for #7605 (instead of for this issue, which was actually posted earlier ;).

Also available in: Atom PDF