Defect #6837

The new project link path is wrong in project show views

Added by Olivier Farlotti almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2010-11-05
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:1.0.3

Description

Error 404 on /projects/add

The path should be /projets/new to work

I tried to invastigate quickly in root.rb, application_helper.rb, projects_controller.rb, /view/projects/show.rhtml and all seems to be ok.
I just dont understand

History

#1 Updated by Felix Schäfer almost 10 years ago

It was add and now is new since r4069, which has been merged in stable for 1.0.3. Did you restart your redmine and everything else in between after updating? What link did you click on that took you to add?

#2 Updated by Olivier Farlotti almost 10 years ago

Yes i noticed the change from add to new and I restarted Redmine after the cache and session clearing (upgrade from 0.9 to 1.0.3).

The fact is the "new (sub)project" link is well formed in /admin/projects but not in /projects and /projetcts/<project slug>

I use Redmine in a french environment but i guess it does'nt matter

#3 Updated by Axel B. almost 10 years ago

Have a look at the plugins you may have installed. I had the same issue and had a plugin, which extends/ overwrites the project show view (template). After updating merging the plugin template with the new default one everything worked fine again.

#4 Updated by Jean-Philippe Lang almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

#5 Updated by Jiri Kubica almost 10 years ago

Small update - in my Redmine it was problem with plugin redmine_project_filtering
./vendor/plugins/redmine_project_filtering/app/views/projects/index.rhml

Also available in: Atom PDF