Defect #6843

REST API Does Not Include Target Version

Added by Jeremy Walker almost 10 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2010-11-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST APIEstimated time:2.00 hours
Target version:-
Resolution:Cant reproduce Affected version:1.0.1

Description

The REST API for issues does not include the target version of the issue. This is a surprising omission given that the XML returned for issues contains just about everything else available on the normal issues page.

History

#1 Updated by Jean-Philippe Lang almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

In trunk and 1.0.1, the target version is present in /issues.xml and /issues/1.xml.

See:

Note that the tag is omitted if target version is not set.

#2 Updated by Jeremy Walker almost 10 years ago

Ah sorry, my mistake (must have had some un-versioned records without realizing it).

#3 Updated by Jeremy Walker almost 10 years ago

Stupid question though: why is it called "fixed_version" in the API (even for issues with status New, which clearly aren't fixed), but "target version" (which makes much more sense universally) in normal Redmine?

#4 Updated by Jean-Philippe Lang almost 10 years ago

"Target version" is the new display name for this property, but it's still named fixed_version internally and thus in the API.

#5 Updated by Jeremy Walker almost 10 years ago

Ahhhh

#6 Updated by fasdfasd fasdfasdf almost 9 years ago

SPAM

Also available in: Atom PDF