Defect #8524


Error upgrading from 1.1.1 to 1.2.0

Added by Cassiano Monteiro about 13 years ago. Updated about 13 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Affected version:


After all the upgrading steps, when I try to load the Redmine home page, html the source code is generated, but show as plain text on the web browser.

On my mongrel.log, i got these errors:

** Starting Rails with production environment...
** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  INT => stop (no re** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  INT => stop (no re** Rails loaded.
** Loading any Rails specific GemPlugins
** Signals ready.  INT => stop (no restart).
** Mongrel 1.1.5 available at
** Use CTRL-C to stop.
Fri Jun 03 17:51:50 -0300 2011: Error calling Dispatcher.dispatch #<NoMethodError: undefined method `[]' for nil:NilClass>
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/cgi.rb:108:in `send_cookies'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/cgi.rb:136:in `out'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/http_response.rb:65:in `start'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/cgi.rb:135:in `out'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/rails.rb:81:in `process'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:159:in `process_client'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:158:in `each'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:158:in `process_client'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:285:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:285:in `initialize'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:285:in `new'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:285:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:268:in `initialize'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:268:in `new'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel.rb:268:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:282:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:281:in `each'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:281:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:128:in `run'
C:/webserver/Ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/command.rb:212:in `run'
C:/webserver/Ruby/bin/mongrel_rails:19:in `load'

My gem list:

*** LOCAL GEMS ***

actionmailer (2.3.11, 2.3.5)
actionpack (2.3.11, 2.3.5)
activerecord (2.3.11, 2.3.5)
activeresource (2.3.11, 2.3.5)
activesupport (2.3.11, 2.3.5)
cgi_multipart_eof_fix (2.5.0)
gem_plugin (0.2.3)
i18n (0.4.2)
mongrel (1.1.5 x86-mingw32)
mongrel_service (0.3.4 i386-mswin32)
mysql (2.8.1 x86-mingw32)
rack (1.1.0)
rails (2.3.11)
rake (0.8.7)
rmagick (2.12.0 mswin32)
win32-service (0.5.2 mswin32)

Running on Apache/Windows XP x64.

Actions #1

Updated by Etienne Massip about 13 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Mongrel < 1.2 + Rails 2.3.11 require monkey patch, see RedmineInstall.

Actions #2

Updated by Cassiano Monteiro about 13 years ago

  • Status changed from Closed to Reopened

I tried the patch from mongrel.rb file, I still had the same problem. Is the patch_for_mongrel.rb file different?

Mongrel 1.2.0 is already out?

Actions #3

Updated by Tom Rochette about 13 years ago

I had this same error a while ago, fixed it by using some of the stuff on Might be helpful to you.

Actions #4

Updated by Cassiano Monteiro about 13 years ago

It´s basically the same as the one from, just with more versions on the top.

But it´s completely different from mongrel.rb that I have installed from version 1.1.5 here. How should I apply the patch? Add all the content from the patch file to the one I have? Or just overwrite it?

Actions #5

Updated by Alfredo Bonilla about 13 years ago

Hi, you have to place the mongrel.rb file in your redmine/config/initializers. We had a problem with the gems. We didn't install mongrel and mongrel_cluster gems. If you look at the patch code, the first IF sentence is searching for the version of the mongrel gem... so, once installed, everything works perfectly.

Actions #6

Updated by Etienne Massip about 13 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF