Defect #8585 need for different repos with different users always user credentials

Added by C. X. over 11 years ago.

Status:NewStart date:2011-06-10
Priority:HighDue date:
Assignee:-% Done:


Category:SCM extra
Target version:-
Resolution: Affected version:



I have a lot of projects with repositories for it, but everyone isn't assigned to each project.
So I tried something, the user admin is assigned to project 1 and the user testuser to project 2.
I open the repository with my browser. First I opened the repo of project 1 and can authenticate myself.
After that I opened the second repo with the right user credentials and it worked.
But when I tried to browse in my first repository I have to authenticate again.

Eclipse shows with Subclipse the same behavior.
I think there is some problem with the authenticate method of Redmine, because similar configurations works with other authentication scripts.

Redmine: trunk
mysql: 5.1.49-3
ruby: 4.5
svn: 1.6.12dfsg-5
rails: 2.3.11
rack: 1.1.2

Also available in: Atom PDF