Defect #9672

Message-quoting in forums module broken

Added by Mischa The Evil over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2011-11-27
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:


Target version:1.3.0
Resolution:Fixed Affected version:


After got an update (I believe somewhere in the past weekend) and I started triaging/supporting again today, I first noticed that the message-quoting functionality (both for topics and messages actually) in the forums module is broken. The buttons are rendered correctly but after pressing it, nothing happens.

At first in the understanding that this might be an issue on r.o only, I tried to reproduce this behavior on my Redmine test-box (currently) running source:/trunk@7939 and found out that this is actually a defect in, at least, current Redmine trunk.

The request is logged without errors (at least in my understanding) as:

Processing MessagesController#quote (for at 2011-11-27 21:14:20) [POST]
  Parameters: {"board_id"=>"1", "action"=>"quote", "authenticity_token"=>"<token>", "id"=>"2", "controller"=>"messages"}
Completed in 12ms (View: 1, DB: 1) | 200 OK [http://host.domain.tld/boards/1/topics/quote/2]

I already tried to see if there were recent changes that had the possible impact to result in this broken functionality, like routes changes, but couldn't find anything.

FTR, the quoting in the issues module works fine.

  • Redmine: source:/trunk@7939
  • Ruby: 1.8.7 [x86_64-linux] (REE 1.8.7-2011.03)
  • RubyGems: 1.3.7
  • Rack: 1.1.2
  • Rails: 2.3.14
  • MySQL: 5.1.41
  • Browser: Mozilla Firefox 7.0.1

Please let me know if more information is required.

Associated revisions

Revision 7961
Added by Jean-Philippe Lang over 9 years ago

Update MessagesController#quote to match the input id changed in r7682 (#9672).

Revision 7962
Added by Jean-Philippe Lang over 9 years ago

Adds test for r7961 fix (#9672).


#1 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Resolved
  • Resolution set to Fixed

Fixed in r7961, r7962.

#2 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Jean-Philippe Lang

1.2-stable is not affected.

#3 Updated by Mischa The Evil over 9 years ago

That's fast... ;) I now understand what was wrong, thus educational too ;)

#4 Updated by Etienne Massip over 9 years ago

  • Target version set to 1.3.0

Also available in: Atom PDF