Plugins Directory » Redmine Bootstrap Kit

Author: Nicolas Rodriguez
Website: http://jbox-web.github.io/redmine_bootstrap_kit/
Code repository: https://github.com/jbox-web/redmine_bootstrap_kit
Registered on: 2014-04-19 (over 3 years ago)
Current version: 0.2.5
Compatible with: Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x
User ratings:   (3)

As Redmine does not support asset pipeline, we need to install JQuery plugins as Redmine plugins to load them globally.

It provides :

Installation notes

The documentation is on Github.

Changelog

0.2.5 (2016-12-31)

Compatible with Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Add BS col-md-4 and col-md-8
  • Remove source from Gemfile

0.2.4 (2015-11-18)

Compatible with Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Set JQuerySortable dataType to 'script'
  • Fix ajax indicator with modals

0.2.3 (2015-04-01)

Compatible with Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Add CodeMirror lib
  • Add HighCharts lib
  • Add jQueryFileTree lib
  • Add ZeroClipboard lib
  • Add helpers to load JS librairies

0.2.2 (2015-03-14)

Compatible with Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Add helpers for BootstrapSwitch and Ajax rendering

redmine_bootstrap_kit-0.2.2.tar.gz (480 KB) Nicolas Rodriguez, 2015-03-14 03:54

0.2.1 (2015-03-04)

Compatible with Redmine 3.3.x, 3.2.x, 3.1.x, 3.0.x, 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Bump to FontAwesome 4.3.0
  • Bump to last version of JQuery TagIt
  • Add Rails and JS helpers for TagIt

redmine_bootstrap_kit-0.2.1.tar.gz (479 KB) Nicolas Rodriguez, 2015-03-04 01:10

0.2.0 (2015-01-26)

Compatible with Redmine 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

Changelog :

  • Fix compatibility with Redmine 2.6.1

redmine_bootstrap_kit-0.2.0.tar.gz (423 KB) Nicolas Rodriguez, 2015-03-04 01:09

0.1.0 (2014-04-19)

Compatible with Redmine 2.6.x, 2.5.x, 2.4.x, 2.3.x, 2.2.x, 2.1.x, 2.0.x.

redmine_bootstrap_kit-0.1.0.tar.gz (278 KB) Nicolas Rodriguez, 2014-04-19 16:20

User ratings

  by Christoph Matt 5 months ago

Straight forward Bootstrap Integration!

  by Thierry Brochu about 2 years ago

  by Nicolas Rodriguez over 3 years ago