RedmineUpgrade » History » Version 11

« Previous - Version 11/82 (diff) - Next » - Current version
Mischa The Evil, 2009-02-23 21:45
Fixed formatting


Upgrading

Upgrading from a SVN checkout

Before upgrading, check that you meet the requirements for the version you're about to install.

1. Go to the Redmine root directory and run the following command:

svn update

2. Migrate your database (please, make a database backup before doing this):

rake db:migrate RAILS_ENV="production" 

3. If you upgrading from SVN r2493, you must generate secret for cookie store:

rake config/initializers/session_store.rb

Also remember that Redmine from r2494 now uses Rails 2.2.2, don't forget upgrade existing installation:

gem install rails -v=2.2.2

3. Clear the cache and existing sessions:

rake tmp:cache:clear
rake tmp:sessions:clear

4. Restart the application and go to "Admin -> Roles & permissions" to check/set permissions for the new features, if any.

Upgrading from a downloaded release

1. Uncompress the new program archive in a new directory.

2. Copy your database settings config/database.yml into the new config directory.

3. Copy config/email.yml.example to config/email.yml and edit this file to adjust your SMTP settings.

4. Go to your new redmine directory, then migrate your database (please, make a database backup before doing this):

rake db:migrate RAILS_ENV="production" 

5. If you upgading from 0.8.x to SVN or 0.9.x, you must generate secret for cookie store:

rake config/initializers/session_store.rb

Also remember that Redmine from r2494 now uses Rails 2.2.2, don't forget upgrade existing installation:

gem install rails -v=2.2.2

5. Copy the RAILS_ROOT/files directory content into your new installation.

6. Start the application and go to "Admin -> Roles & permissions" to check/set permissions for the new features, if any.