Feature #1088

Time logging via commit messages

Added by Jone Marius Vignes over 9 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2008-04-22
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Time tracking
Target version:-
Resolution:Fixed

Description

It would be really nice to have the ability to log time spent on a revision in the commit-message. With distributed systems like git, it would then be possible to register time spent when working offline. Syntax could be something like "refs #11 (00:45)". The comment might be a link to the associated revision.


Related issues

Related to Redmine - Feature #1518: Log time via commit messages Closed 2008-06-23
Duplicated by Redmine - Feature #1331: Allow logging of time via repository commits Closed 2008-05-30

History

#1 Updated by David Gillard over 9 years ago

It would also possibly need to take an activity value as well as the time. +1

#2 Updated by Mischa The Evil almost 9 years ago

Related this issue to #1518 which also contains patches for this.

#3 Updated by Ludovic Aelbrecht over 8 years ago

This seems like a dupe of #1518 to me, instead of just being related to it. Is there a reason this shouldn't be resolved to 'duplicate'?

#4 Updated by Jean-Philippe Lang almost 7 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

See #4155.

Also available in: Atom PDF