Defect #19553

When create by copying the issue, status can not be changed to default

Added by Hirokazu Onozato almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:3.0.2
Resolution:Fixed Affected version:3.0.1

Description

If create a issue in the following procedure, the status is not correctly registered.

  • Copy an issue. (At this point, the status is "Assigned")
  • Change to other status. (Change to "New")
  • Pressed to the Create button. Issue is created.
  • Created issue status is registered in the pre-changed status. (Registered status is "Assigned")

Related issues

Duplicated by Redmine - Defect #19565: problem with the ticket situation copied, the situation t... Closed

Associated revisions

Revision 14158
Added by Jean-Philippe Lang almost 3 years ago

When create by copying the issue, status can not be changed to default (#19553).

History

#1 Updated by Go MAEDA almost 3 years ago

  • Category set to Issues

I have confirmed the behavior.
It seems to be caused by source:trunk/app/controllers/issues_controller.rb@13535#L430, introduced in r13535.

#2 Updated by Go MAEDA almost 3 years ago

Workaround for this issue:

Index: app/controllers/issues_controller.rb
===================================================================
--- app/controllers/issues_controller.rb    (revision 14155)
+++ app/controllers/issues_controller.rb    (working copy)
@@ -425,7 +425,7 @@
     @issue.start_date ||= Date.today if Setting.default_issue_start_date_to_creation_date?

     if attrs = params[:issue].deep_dup
-      if params[:was_default_status] == attrs[:status_id]
+      if action_name == 'new' && params[:was_default_status] == attrs[:status_id]
         attrs.delete(:status_id)
       end
       @issue.safe_attributes = attrs

#3 Updated by Go MAEDA almost 3 years ago

  • Target version set to 3.0.2

#4 Updated by Go MAEDA almost 3 years ago

  • Duplicated by Defect #19565: problem with the ticket situation copied, the situation this resetting added

#5 Updated by Jean-Philippe Lang almost 3 years ago

  • Subject changed from When create by copying the issue, status can not be changed. to When create by copying the issue, status can not be changed to default
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Fix committed in r14158 with a test.

#6 Updated by Jean-Philippe Lang over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF