Defect #20425

fn1. not working in tickets

Added by Robert Schneider about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution: Affected version:3.1.0

Description

In issues fn links don't work. In Redmine Guide (example) it is working, but not in issues. The foot note itself is rendered correctly but the link is not.

Example:

This is a test. [1]

fn1. Here is the footnote.

will be this:

This is a test. [1]

1 Here is the footnote.

So [1] looks like [1]. It is not replaced by a link to the foot note (with blue foreground color).


Related issues

Related to Redmine - Feature #6269: RedCloth 4 support New

History

#1 Updated by Go MAEDA about 4 years ago

Please try placing brackets just behind alphanumeric characters like the following:

This is a test[1].

#2 Updated by Michael Goegel about 4 years ago

Hi Robert,
I encountered a similar problem using wiki. The footnotes only work directly after letters. Brackets and other special characters lead to the behavior you posted.
Regards
Michael

#3 Updated by Go MAEDA about 4 years ago

#4 Updated by Go MAEDA about 4 years ago

I tested RedCloth 4.2.9 (not on Redmine). It can handle any of the following:

This is a test. [1]
This is a test.[1]
This is a test[1].

#5 Updated by Mischa The Evil about 4 years ago

For clarity's sake: current Redmine's Textile implementation (customized RedCloth 3.0.4) only supports the syntax that is used in the third and last example in the previous note by Go MAEDA.

#6 Updated by Robert Schneider about 4 years ago

  • Status changed from New to Resolved

Another test1.

1 Here is the footnote.

Okay, true. So this is not a bug/defect. Rather it can be seen as a lack of documentation. One just has to know how the footnote can be used. But of course, switching to the newer version of RedCloth would be nice.

Thank you for the fast treatment!

#7 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF