Defect #23377

Don't show "status" field when creating a new version

Added by Tobias Fischer over 1 year ago. Updated about 1 year ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Roadmap
Target version:3.4.0
Resolution:Fixed Affected version:3.3.0

Description

When creating a new version from within the issue form field with the modal dialogue, the "status" option should be hidden.
It makes no sense to set this newly created version to "closed" or "locked" because then, it isn't selectable from the isuee form field.


Defect duplicate of Feature #21416 as Feature request don't get ANY attention by the Redmine team.
And in fact, this one here could also be called a bug instead of a feature...

do_not_show_status_field_on_new_version_form.patch Magnifier (2.29 KB) Marius BALTEANU, 2016-07-25 01:51


Related issues

Duplicated by Redmine - Feature #21416: Hide "status" field from new version form when it is call... Closed

Associated revisions

Revision 15784
Added by Jean-Philippe Lang about 1 year ago

Don't show "status" field when creating a new version (#23377).

History

#1 Updated by Jake Kemme over 1 year ago

I agree, this option makes no sense here.

A quick fix for your instance, if this is causing user issues would be to hide it via CSS

Add to your theme application.css:

/* Hide version status selection in version create dialog */
.ui-dialog .new_version p:nth-child(3) {
    display: none;
}

#2 Updated by Tobias Fischer over 1 year ago

Hi Jake,

thanks for the smooth workaround. Werks very well!

#3 Updated by Marius BALTEANU about 1 year ago

I made a patch that fixes/implements this without CSS.

The patch passes all the tests and adds two new assertions:
  1. new version form doesn't contains the status field
  2. edit version form contains the status field.

#4 Updated by Marius BALTEANU about 1 year ago

Tobias Fischer wrote:

When creating a new version from within the issue form field with the modal dialogue, the "status" option should be hidden.
It makes no sense to set this newly created version to "closed" or "locked" because then, it isn't selectable from the isuee form field.

In my opinion it makes no sense in all pages from where you can add new versions, not only in the modal dialogue. I think there are very few cases when you want to add a locked/closed version.

#5 Updated by Go MAEDA about 1 year ago

  • Target version set to 3.4.0

Marius BALTEANU wrote:

In my opinion it makes no sense in all pages from where you can add new versions, not only in the modal dialogue. I think there are very few cases when you want to add a locked/closed version.

I agree with you.

Thanks for the patch. It looks good to me.
Setting target version to 3.4.0.

#6 Updated by Tobias Fischer about 1 year ago

Marius BALTEANU wrote:

In my opinion it makes no sense in all pages from where you can add new versions, not only in the modal dialogue. I think there are very few cases when you want to add a locked/closed version.

Yeah, totally agree with you! :)

Thanks for the patch! Looking forward to see this implemented!

#7 Updated by Toshi MARUYAMA about 1 year ago

  • Duplicated by Feature #21416: Hide "status" field from new version form when it is called from modal dialogue from the issue form added

#8 Updated by Jean-Philippe Lang about 1 year ago

  • Subject changed from "status" field should not be displayed when "new version" form is displayed as modal dialogue from the issue form to Don't show "status" field when creating a new version
  • Category changed from Issues to Roadmap
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch committed, thanks.

Also available in: Atom PDF